Autodafe not visible and usable; why ?

hello, i do not understand, why i can not use the autodafe plugins inside my folder ~/.Rack2/plugins/Autodafe.

it is downloaded without any error and the *.so lib and *.json files are there.

i’m on linux Fedora 37.

any ideas? should i compile it from source? if yes, where is the destination for version 2.0.0. i only see 0.6 on github.

Regards Karl

It’s freeware, not open source.

Maybe you have to subscribe to the plugins on library.vcvrack.com ?

hello, yes i know the difference, but forgot. If i login with my account on library.vcvrack.com i see, that the modules are installed. the only thing i see in log.txt is the following:

[0.193 info src/plugin.cpp:137 loadPlugin] Loading plugin from /home/held/.Rack2/plugins/Autodafe [0.193 warn src/plugin.cpp:203 loadPlugin] Could not load plugin /home/held/.Rack2/plugins/Autodafe: Failed to load library /home/held/.Rack2/plugins/Autodafe/plugin.so: /home/held/.Rack2/plugins/Autodafe/plugin.so: undefined symbol: __cxa_pure_virtual

does anyone knows, what is missing?

maybe libstdc++-static is missing ?

Something needs an update with that plugin, It’s stuck in an endless update loop.

image

Anyway, here’s what i get on my Fedora 37:

only the drum plugins show up.

googled the error - no exact matches, but i found this:

rpm -qa | sort | grep c++

gcc-c++-12.2.1-4.fc37.x86_64
libsigc++20-2.10.8-2.fc37.x86_64
libstdc++-12.2.1-4.fc37.i686
libstdc++-12.2.1-4.fc37.x86_64
libstdc++-devel-12.2.1-4.fc37.x86_64
libstdc++-static-12.2.1-4.fc37.x86_64

I get the same error as you.

[3.874 info src/plugin.cpp:137 loadPlugin] Loading plugin from /home/jpn/.Rack2/plugins/Autodafe
[3.878 warn src/plugin.cpp:203 loadPlugin] Could not load plugin /home/jpn/.Rack2/plugins/Autodafe: Failed to load library /home/jpn/.Rack2/plugins/Autodafe/plugin.so: /home/jpn/.Rack2/plugins/Autodafe/plugin.so: undefined symbol: __cxa_pure_virtual
[3.878 info src/plugin.cpp:137 loadPlugin] Loading plugin from /home/jpn/.Rack2/plugins/Autodafe-DrumKit

image

I’ve never used them - suggest OP mails about the bug.

yes, the drums show up and runs well.

FYI, OK in Ubuntu 22.10.

Strange. I’m running Ubuntu Studio 22.10 with VCV Rack Free 2.2.2 and I have this ‘non-stop-want-update-autodafe’. Btw. there is another thread about this: Autodafe plugins (not drums) failing to update

It doesn’t want to non-stop update here.

This was on a clean ubuntu, fresh install of Rack Free 2.2.2 from vcvrack.com zip

hello, i wrote an email to the author. he answered quite fast and informed me, that he will have a look into it. could take a while… will see.

2 Likes