Audio Output in Version 2.0.5

Hello all. Since I did the 2.0.5 update I can’t switch my audio output XUSB. I work with the Behringer X32Rack. When I select the output under Asio, it is not taken over. Under version 2.0.4 everything worked fine. The driver Asio4all also still works. Are there any similar experiences here? Greetings Jörg

Hello all ! I have just install the version 2.0.5 and vcv rack (standalone) doesn’t launch with a patch. With an empty patch, it launches but when i select ASIO / Presonus ASIO driver/ 512, VCV Rack exit… I’m under Windows 10. All was working fine with version 2.0.4. Thanks

Are you running ASIO at 44.1khz? In the linux version there is a bug where you cannot connect to an output if the audio server is running at anything other than 44.1 so perhaps it affects Windows as well?

Hello all! I can confirm there went definitely something wrong with the 2.0.5 Update regarding Audio Drivers. My Audio Interface resets everytime when I open VCV Rack Pro 2. It seems to set all Parameters new and reboots even if the Settings did not change. After rebooting the Interface, everything seems to work normal - but it is i a little bit annoying. This does not occur < 2.0.5, so i downgraded. OSX 11.6 - MP2019 - UAD Apollo x6 Hexa @48kHz Greetings!

Sounds like the same bug then. It’s been reported for linux but you might want to let support know that it is causing problems on other platforms too -

My sound card is configured with a block size of 512, all my patches are with this parameter. But VCV Rack 2.0.5 is launching with a block size ok 256 (and my presonus card too, i don’t know why). So when i wanted to configure with 512… vcv rack crashed. It seems yes that the 2.0.5 initializes some audio parameters.

From the 2.0.5 changelog:

  • Set audio device default sample rate to 44100, and block size to 256 except DirectSound to 1024.
1 Like

Yes, that must be the case: It inititalizes with these settings, and then it switches back automatically to the settings i have stored in VCV - in my case 48 / 512 - and then runs fine.

Would be great if this could be restored to the old behaviour, because it takes some time to twice reboot my Apollo, and it causes some clicks. and audible pops my speakers and ears do not like very much.


But it is kind of handy to have settings for this in VCV. I think I’ve seen other softwares have setting like this in the DAW also?

If would be nice if VCV could tell is the interface was already set to the specified settings and not set it twice? Or some way for the user to turn off this (rather nice) feature?

I’m guessing they changed it because the old way caused problems for some people too.

1 Like

i think this was the old behaviour - to set it to the settings that are stored in the patch that is loaded after opening VCV. now it seems to set it to the default settings when VCV is opened, and afterwards set it to the settings stored in the patch that is loaded (was last opened).

1 Like

additionally, what is a little bit annoying, and i discovered right now:

this also happens, when i open a new patch while VCV is already running.

  • Bug reports and feature requests for VCV Rack are allowed in order to discuss with other users, but they are not handled by VCV developers. Contact VCV Support for reporting bugs and requesting features.

i already did, described the problem, and linked to this post :wink:

Thanks ! I didn’t find the changelog before i made the update… crazy man i am :partying_face:

This “new” behavior is interface type dependent and breaks standards. JACK (pro-audio sound server used by many professionals on Linux), for example, does not negotiate quant changes with client software. The client must adjust it’s quant to whatever the server is offering. That is usually the standard - clients do not dictate system-wide parameters to servers. For Linux pro users that use JACK this is a dead end. They have to either change their JACK quant to 256/44100 system-wide or not use Rack. Linux users with PipeWire that emulates a JACK server, can adjust their quant per application, but this must be done before launching the application as again, JACK does not allow negotiating quant. Add to this that the PulseAudio support in Rack is buggy (was reported to support, including a solution) and it seems that Linux folks don’t have much choice… :worried:


Rack2 git is 12 months behind on rtaudio

master recently changed to return codes instead of exceptions, they say it breaks compatibility.

But maybe worth a merge ? Perhaps it makes the handling the same on win/lin/mac ? Perhaps someone could explain ?

On Windows 11, I have to select another ASIO interface, before I can select Voicemeeter ASIO. I can’t select Voicemeeter first. It was working with 2.0.4 for the first time, but then broke again in 2.0.5.

The PulseAudio problem is a known bug in RTAudio and was fixed in version 5.2.0 which is also the latest release. I’ve tested it with Rack and PulseAudio works well. I’ve sent my findings to support@ about three weeks ago. Unfortunately, this is not going to fix the issue with JACK as, by protocol definition, JACK does not negotiate quant. Rack should follow all other JACK aware software and adjust its quant based of the server.

1 Like

Same here, Win11, Audient ID 14MKII slaved to adat-IO @48kHz. Even if I set the VCV engine to 48kHz vcv-audio-module is forcing the interface to 44.1. When I try switching vcv audio to 48kHz it crashes. Is there somewhere a download link for vcv rack 2 pro v2.0.4 or 2.0.3?

Just copy the link on the pro 2.0.5 download button and change the 2.0.5 in the URL to 2.0.4