Audio-8 crash when changing sample rate

I’ve got my interface set at 48khz, and the VCV engine set at 48khz. Yet when I load AUDIO-8 is loads at 44.1khz, I then choose my interface (MOTU) and change the samplerate to 48khz, this is where VCV freezes and crashes. This happens even if I only have the core AUDIO-8 module open. Any ideas? I have no issues changing the sample rate in DAW’s, maxmsp or my interface settings.

INFO OS: Windows10 VCV: 1.1.6

I’ve have similar crashes of VCV (Win10,ES-8 interface). . The driver for the ES-8 in my case defaults to ADAT clock and it has to be on INTERNAL clock to work properly. If I forget to verify the correct settings before starting VCV then it’s already too late. :upside_down_face:

Try getting all settings in Windows done first and then start VCV.

Hi @guillaume.dujat , and welcome to the forum!

In my former setup when i had the MOTU ULmk4 the only way to change the audio device sample rate in VCV was to change it from the MOTU control panel. ( i think even before starting VCV Rack, can’t remember this anymore).

And yes in other DAW software i could do it from the DAW application itself

So depending on which MOTU interface you have, you need to launch the device control panel and change it from there.

Hello all, I’ve got the exact same issue as @guillaume.dujat, but in VCV Rack 2.

Has this been resolved?

The AUDIO-8/16 defaults to 44.1 kHz despite the MOTU interface being set to 48 kHz and the VCV rack engine being explicitly set to 48 kHz, too.

It’s impossible to manually change the (wrong) setting of the AUDIO-8/16 module without VCV rack crashing. Apparently it also seems to force the interface to 44.1 kHz.

I may be wrong, but believe this is a change that came in with 2.0.5 so if you revert to an earlier version like 2.0.4 (if you still have the installer) it may fix it. I’m avoiding 2.0.5 or later until I know this isn’t an issue as my interface and all my ADATs etc are set to run at 48kHz.


Thank you for that! <3 Got back to 2.0.4 and did a quick test. Apparently this VCV Rack build respects the 48 kHz setting of the interface.

1 Like

Same here.

Yeah, it was this change in 2.0.5:

  • Set audio device default sample rate to 44100, and block size to 256 except DirectSound to 1024.

With this comment in the code:

// Most people prefer 44100 default sample rate although many devices report 48000 from deviceInfo.preferredSampleRate.

Maybe he’s right, and most people would prefer that. It’s not a change I’m happy about either, and switching audio interfaces now is a pain in the butt, and I’ve noticed it also adds to Rack’s startup time. Maybe chime in folks: Do you prefer this change or not?

nothing should ever attempt to reset my audio device, apart from me. I have never had any issue before this 2.0.5 build with things respecting what the audio bitrate of the default sound device. Also, honor the Engine rate as clearly the engine is still reporting 48kHz 256 block size, which is correct.

1 Like

If this was an issue affecting users who had systems running at 44.1 and I wasn’t aware then I can understand some fix was needed, but to impose this default seems to break a lot of implementations. Either remove the default (my preference) and make people set it or if that’s impossible for whatever reason then maybe offer different ‘flavours’ of Audio-2,8,16 that have different defaults and let people pick the one that’s right for them?


I’ve read about this causing an issue on Linux and Windows too I think - can anyone confirm if it is also a problem on Mac?

Everything in my chain runs at 48k so I have held off updating to 2.0.5 for now in case it causes issues.

I run on M1 mac

seems to me that that would be sensible, set it as a default which one you want and be done…

What problem is this change trying to solve? I’m struggling to think of a scenario where you wouldn’t want a program to connect to the audio server at whatever settings it is running at. I’m amazed that the current Rack is unusable for a lot of people and there hasn’t been an update to fix it yet.


+1 for no fixed 44.1 khz default in VCV

It will break my workflow too as my rig is ADAT at 48khz which all DAW’s respect with their preference settings.

1 Like

@pgatt Has this been logged as an issue? This new imposition of default Audio settings in Rack 2.0.5 is going to cause many of us problems.

see also: Audio Output in Version 2.0.5 - #29 by Kabelix

Answer from VCV: Thanks for the bug report, and sorry you’re experiencing this issue! This is a known bug and we are hoping to fix it soon.

So theyre on it, which is good :wink:

1 Like

Does anyone know where I can get 2.0.4? I’m having the same issue with 2.0.6. Thanks!

If you go to the download link for the current version you can change the numbers in the url to what you need.

I would provide a link but suppose it depends if you’re using Pro or not.