ARM64 Crostini Chromebook Build [Done: A bit hacky]

Currently;a=blob_plain;f=config.guess;hb=HEAD Cfg/config.guess for libsamplerate required updating. Available as it might change, from the google drive link below).

Then make dep worked. Apparently 1 string function warning. Now doing make.

EDIT: VCV - Google Drive some built plugins. I think distributing the Rack build itself is not allowed. The plugins thus are all open source and free so that the licence is satisfied by the source from the repository (usually on github, found by the link to the source from the VCV library). DON’T use any other repository (beware name supply chain hacking). Some repositories are not named after the plugin slug. Some are but need some capitalization, and some are verbatim slug named.

Screenshot 2023-01-08 00.05.29

ALSA or PulseAudio?

PulseAudio has better immunity to screen window resize jitter. 4 threads possible and running picture in picture youtube also.

Build SSD 2.4 GB. Drop the file in first post of thread here

Minor issue of cursor turning into white square solved with click. No library, as developer mode only. Must build modules from source. What to do after fundamental besides own? That’s maybe tomorrow. Now beer :smiley:

EDIT: VCV Manual - Building follow Ubuntu instructions. When the make error happens place file in libsamplerate-1.9/Cfg folder. make again. … yes that console clears up where the Fundemental git repo is placed.

Happy Crimbo and New Year '23

PS: perhaps an important edit. The cursor changing into a white square might be a ChromeOS/Wayland issue, but could indicate an assignment blit order race or sequence wrong in rack. ie, at set draw before fill, and a container interaction of set draw to export container, hence fill fail until check shape change on click?

NB: I can only debug to some extent kappa Chrome OS Updates and the rest is pricey of chromebook count and accommodation space and time. Also I haven’t read the chromebook source so there is that … maybe some musical beings around there might help?

@jackokring - maybe this could be interesting for you: GitHub - hexdump0815/rack-dockerbuild-v2: docker based build based on the vcvrack v2 sources on armv7l and aarch64 on ubuntu 18.04 and raspbian bullseye … also in case you would like to run a real linux on your arm64 chromebook, maybe this is interesting too: GitHub - hexdump0815/linux-mainline-on-arm-chromebooks: running linux mainline on arm chromebooks - for example: samsung xe303c12 and xe503c12 (snow and peach), acer c100, c101 and c201 (veyron speedy, minnie etc. and gru bob and kevin), medion s2013 and s2015 (veyron jaq, mighty etc.), acer cb5 311 (nyan big), lenovo n23, acer r13 (oak elm and hana), lenovo duet (kukui krane) and most probably many many more over time ... and imagebuilder/systems/chromebook_kukui at main · hexdump0815/imagebuilder · GitHub … my aaarch64 build of rack runs quite nice on mainline linux on my kappa chromebook :slight_smile:

all the best wishes and good luck - hexdump

She works armv8-a+fp+simd as the compiler options which flew by said with an aarch64/arm64. So I assume it builds using NEON and or other ARM core FPU vector stuff.

Suggest 1.9-cvonfig fork of libsamplerate?

The gate from the QWERTY keyboard always seems to be active. Timer clocking internally works. CV note from QWERTY works. Compile of my own KRTPluginA module works, and so works with at least one arm64 architecture. I can therefore keep up development. :smiley:

EDIT: I find

helps with the background load stress testing (youtube playing).

EDIT2: The QWERTY gate seems hit and miss and sometimes latchy.

Some wine and

Screenshot 2023-01-09 19.53.08

Release Chromebook arm64-a+fp+simd (hp 11a nr0000na) · jackokring/KRTPluginA · GitHub for my chromebook plugin build.

I don’t think I’m allowed to distribute the rack binary.

Screenshot 2023-01-09 20.21.21

And some classics

Screenshot 2023-01-10 13.14.16

oops no spring delay.

EDIT: I may do a removal fork later but not soon.

Screenshot 2023-01-10 13.17.30 OK.

GitHub - jackokring/Befaco for a nice Befaco sans spring reverb.

It’s an upstream SDK issue (likely default system when system not recognised) similar to need for new config.guess but different.

So yep, @Andrew provided an architecture independent fix, and hopefully will be cleaned of temptation. So the Befaco modules build nicely.

Excellent, the complete base system builds. As far as I know … It looks almost the same apart from it’s got new better performance metering graphs…

Maybe the config.guess fix will come in a version update in the future. It’s still a thing behind the scenes to make the build farm though.