30 second delay in startup - white screen

Hi all,

When I first launch VCV Rack (either Free or Pro) on my PC, the screen is just a full white window for 30+ seconds until everything just sort of snaps in. From that point on, functionality seems fine. It’s just a huge delay on start-up. (Though if I have anything running, I can hear the output immediately even while the screen is blank, so I know it’s not “stuck”.)

I’ve tried clearing out all my plugins, with no change, and it happens no matter what autosave I have.

I’ve seen others report this same issue, but never saw any resolution for any of them. The log file also doesn’t show anything shocking, other than a huge 30-ish second gap.

For example, a snippit of the log from startup:

[0.656 info src/app/RackWidget.cpp:327 fromJson] Creating module widget VCV VCA
[0.656 info src/window/Svg.cpp:28 loadFile] Loaded SVG C:/Program Files/VCV/Rack2Pro/res/ComponentLibrary/Plug.svg
[0.657 info src/window/Svg.cpp:28 loadFile] Loaded SVG C:/Program Files/VCV/Rack2Pro/res/ComponentLibrary/PlugPort.svg
[0.657 info adapters/standalone.cpp:267 main] Running window
[4.192 info src/network.cpp:150 requestJson] Requesting JSON GET https://api.vcvrack.com/version?edition=Pro
[4.364 info src/network.cpp:150 requestJson] Requesting JSON GET https://api.vcvrack.com/user
[4.779 info src/network.cpp:150 requestJson] Requesting JSON GET https://api.vcvrack.com/library/manifests?version=2
[5.140 info src/network.cpp:150 requestJson] Requesting JSON GET https://api.vcvrack.com/modules
[40.896 info src/patch.cpp:254 saveAutosave] Saving autosave D:/Users/Jeff/Documents/Rack2/autosave/patch.json
[40.902 info src/settings.cpp:498 save] Saving settings D:/Users/Jeff/Documents/Rack2/settings.json
[40.908 info src/window/Svg.cpp:28 loadFile] Loaded SVG C:/Program Files/VCV/Rack2Pro/res/ComponentLibrary/Rail.svg
[40.916 info src/window/Window.cpp:50 loadFile] Loaded font C:/Program Files/VCV/Rack2Pro/res/fonts/ShareTechMono-Regular.ttf

Anybody have any ideas?

If you then close Rack and restart does it take 30 seconds again, or is it (much) faster ?

Same every time, even on successive opens of an empty panel.

Has this always been the case ?

Mine took a long time starting up.

I used Sysinternals process explorer to see what was going on. It was spending a lot of time querying the registry for keys that didn’t exist(?). (I didn’t keep the log, and it’s different now, after the change)

Picture of process explorer filter setup to show “rack.exe” process.

I turned off some windows safety features:


On this computer, from the first day, yes. (Which was only a couple weeks ago.)

It also doesn’t happen that way on my Mac, btw… same account and same set of plugins.

1 Like

Good thought, but I already have Smart App Control turned off on this computer, so no effect there.

However, I also checked out Process Monitor and, you’re exactly right… that entire time it appears to be walking a whole tree (or the entirety?) or my registry. That’s odd. Including a bunch of non-existent reg entries.

also, I usually remove this, but I don’t know if you have any steinberg software installed. I don’t use it, and it adds a couple of seconds to the startup of any midi software.


1 Like

It’s strange - my VCV loads just fine, but recently my Visual Studio Code started to take a long time to come up. Same thing - I get an empty frame, then a long time later the rest comes in. I’m on win11, btw.

I’m also on Win 11… forgot to mention that.

3’rd party anti-virus software?

Just started experiencing this intermittently in the last few days, my log is similar

[7.518 info src/network.cpp:150 requestJson] Requesting JSON GET https://api.vcvrack.com/modules [32.488 info src/patch.cpp:254 saveAutosave] Saving autosave C:/Users/me/Documents/Rack2/autosave/patch.json

Does that suggest that an API query took ~25 seconds? Maybe not if it isn’t affecting everyone.

I do have one running, but turned it off and the start time didn’t change.

I don’t use third party anti-virus, but as I mentioned I am having the problem with Visual Studio Code, but not with VCV.

This is interesting. Do you play games on the system in question? I do.


Okay, I “fixed” this, but can’t say for certain which of a few things I tried did it.

Here’s what I did:

  1. I followed @Jens.Peter.Nielsen lead by looking at the process log when starting rack.exe and it definitely spent a long time trying to parse non-existent registry entries for joystick buttons on one particular directinput device that didn’t seem to actually exist, among other things, so I went through my connected devices and removed anything I didn’t recognize (and several that I did) just hoping to drop that registry entry. It didn’t have any immediate affect, but might have been part of the problem and needed a restart to take effect.
  2. I did a windows update, even though it showed me as up to date. And, I suspect crucially, I turned on the “get the latest updates as soon as they’re available” switch, which did actually pull something down and ask for a restart.

After rebooting, now it’s lightning fast on startup, even with a large setup on autosave. It’s wonderful.

Hopefully this helps others in the future… main learning is that it was almost certainly not a VCV Rack issue, but more likely something going on with Windows itself.

Thanks to everyone for their assistance! :+1:


Quick follow-up:

It wasn’t the joystick / device clean up that fixed it. I’m pretty confident it was just the windows update. I re-ran the process monitor on a newer fast startup, and it looks remarkably similar to what it did before, including all the registry nonsense. Even all the missing entries and directinput stuff. It’s all still there, but done in a fraction of a second now. So windows was just doing something really dumb/slow before the update.

1 Like

have you installed Wind 11, 23H2? I haven’t. I don’t usually turn on “latest updates as soon as they’re available”, but I will consider this. Or just wait :wink:


Interestingly, no… the only thing it added was a cumulative update for 22H2. Despite having the “latest updates” checked, I haven’t gotten 23H2. Weird.

I may just be hallucinating, but I swear that sometimes when there is an OS update that I have not applied, things start misbehaving, forcing me into a reboot. I have also seen this on a few major apps. I am on Win11.