Windows 10 - January 9, 2024—KB5034122 broke midi...sort of

HI Some problems with MIDI

Got to bed last night, after working with mapping a akai apc key25 to knobs and snd whatnots - MIDI works fine.

Today I started VCV and noticed that the mappings did not work. I soon noticed that i did not get any mid signals. The device is found in the list of midi devices - but no signals get in from button press.

I started Ableton Live - to confirm - and - no - it did not work in there either - the Buttons did not light up for clips and even though the midi indicator blinked - nothing got in ther either.

The app MidiView for windows showed incoming midi notes - so there was probably nothing wrong with the apc.

I found that the windows update had installed a few updates - so i decided to have a go at removing them.

When I removed the “January 9, 2024—KB5034122” - it started working in Ableton again - but sadly not in VCV

January 9, 2024—KB5034122 (OS Builds 19044.3930 and 19045.3930) - Microsoft Support

I tested several midi modules ,mid mon, midi map and so on - none detects the incoming midi notes

SO this might be a warning to others that has not updated yet AND anybody have an idea of what to do?



Does your Midi device use an installed driver, or is it USB class compliant (no installed driver)?

Its a USB device - no drivers needed.

Update - got the midi working by doing these magic rituals.

First uninstall the windows update mentioned above. Then clear the vcv patch and start over from scratch. (Also lots of restarts, just in case, and uninstallation of devices that had nothing to do with it…) Midi is working again…

Before removing the windows update this did not work, I tested MIDI in after clearing and restarting VCV.

The patch I was working with still does not get any signals… But at least its working on new patches.


It a strange fact (I trust you), on my Win10 PC, this KB doesn’t broke generic MIDI, including VCV Rack 2.4.1 (even on saved patches), Bitwig Studio 5.1, and REAPER 6.78. However, I don’t use Ableton Live.

ah maybe this is what I have been experiencing as well - my midi device used to be identified in most software as “USB MIDI 1”, but is now displaying as “USB MIDI 0” - and while some software, like FL Studio and MidiView, seems to have no problem with it, others - like VCV Rack 2 - no longer registers any input.

furthemore, VCV isn’t noticing my computer keyboard presses either - the only thing that works in the MIDI▶CV plugin is my USB game controller, oddly enough.

VCV is using my MIDI device, as evidenced by other software (like MIDIView) not being able to access it at the same time - and yet it doesn’t seem to be actually taking any imput from it. So strange.

Oh man, thank you for posting this! I’ve been tearing my hair out the past few days trying to get my midi controller to work again, and it was starting to drive me crazy.

I have a Korg nanokey studio, and this is what finally got it working for me again.

  1. Uninstalled the Windows 10 - KB5034122 update:

  2. Uninstalled random midi drivers with the KORG MIDI Driver Uninstall Utility:

  3. Reboot

  4. Reinstalled KORG MIDI drivers

I have no idea if deleting all those MIDI drivers was necessarily, but it was one of the last things I did.

I tried almost everything beforehand, including installing an Android OSC/MIDI control app, which actually got the Korg partially working for some random reason. I wonder how many people are affected by this, or if it’s only a small handful of cases.

I have plenty of problems with Korg windows midi drivers (windows 11) - judging from the number of releases, so does Korg…

In the mean time, I have connected most external midi devices on hubs, and have to disconnect those when i want to use the Korg librarian for the minilogue XD… Or else midi timeouts if korg drivers are >= midi10 in windows…

Hope they get it fixed soon, maybe windows 2 midi services will help.

Honestly, I feel like I’m in bizarro world right now. At first I got the controller working by installing rtpMIDI (which didn’t make any sense), but the touch pads still didn’t work.

Now I got it working by uninstalling the Windows update, but for some reason the scale on my controller is completely off. When I hit C it gives me a D#??

I think the universe is against me. I’m really a simple guy, I just want a keyboard, some knobs, and a few touch pads, why is this so impossible?

The new Windows Midi 2 stack won’t fix badcustom drivers from device manufacturers. It will do lot for devices that are USB class-compliant.

1 Like

Is Korg’s drivers considerably worse than others?

At this point I’m open to hearing suggestions for a more stable MIDI controller.

Microsoft has been trying to persuade manufacturers to implement USB class compliance and stop making custom drivers for looong time, because device manufacturers generally suck at writing drivers (not specific to MIDI devices).


OP had problems with an AKAI apc key 25 - class compliant midi device if i understand the AKAI user guide.

I can only speak of my own experience - and that only counts problems i can’t solve with one Korg minilogue XD module.

My number of samples of controllers are not enough to recommend anything.

But i think i have had most enjoyment out of the Ableton Push 2 as a controller - and I only expect it to work in Ableton Live.

Followed by a 16n clone - that keeps on giving - recently got hold of a new firmware that includes 14-bit midi messages.

16n builds on open source firmware on a teensy (LC) microcontroller, class complaint usb midi. I got the clone from AtoVproject - highly recommend it.


I’m unable to guess whats wrong exactly.

Maybe this thread can help for the pads ? Assuming similarity between Korg and Arturia and the subsystems involved.

1 Like

Thanks for the suggestions. Something magical happened yesterday, all of a sudden the KORG NanoKey Studio started fully working on my desktop. I have no idea what it was, but the touchpads are working now. Unfortunately when I tried connecting it back to my laptop, the touchpads stopped working there, so somehow the problem has migrated to another computer.

I did come across a Reddit post (which I can’t find again) that said something along the lines of having too many MIDI devices will force the driver to assign the device to a channel that is out of bounds for Windows, which might explain using the KORG MIDI Driver Uninstall Utility to delete unnecessary MIDI drivers.

At this point I’m satisfied my keyboard is fully functioning on my desktop and will just have to accept that gremlins live inside my computers.