Win10/Realtek ASIO/No Sound

I’ve just installed on Win 10 Home 64bit and the “Notes” section instructed me to “choose an audio driver and device in the AUDIO-8 module.” I’ve selected “Realtek ASIO (1-2 in, 1-2 out)” and upon pressing the QWERTY or ZXCVB rows I see a waveform in SCOPE but I do not get any audio in my headphones. I have also installed ASIO4ALL which is now also an option, but selecting that does not provide any audio either.

I’m new to this and at this stage I’m unsure of where to look for additional config. Any assistance is appreciated.

As a follow up, I get audio to my headphones if I select WASAPI or DirectSound and my headphones, but only in my left ear. Under ASIO I do not see my headphones as a device. Screenshot attached.

You’re only getting it in your left ear because you’re only sending a signal to output 1 which is the left channel. Run another to output 2.


That did the trick! Thanks so much.

Is it acceptable to proceed using WASAPI instead of ASIO?

If you have not issues with wasapi, why not?

I m Windows specialist, but the use of asio help to avoid latencies, if latencies are not a problem to you , for instance, playing a keyboard with the rack

Btw , some users recommend flstudio asio, take a look of that

yes. you should use whatever works best for you. with a new “pro” sound interface ASIO is usually going to work better. with older hardware/drivers or “built in” audio it’s never obvious which is going to work better.

With my very old M-audio delta-44 WASAPI worked “best” although nothing worked that great. With my new Seteinberg UR22C asio works great.

If you find that you are really serious about audio on your computer, and can afford it, you “should” buy something fancier. There are numerous USB connected devices for a bit over $100.