Where to install NASM, when building VCV-Recorder?


i am trying to build VCV-Recorder from source.

I downloaded NASM and installed it, the default installation went into the c:/users/…/AppData/local/bin/NASM

MSYS is reporting this problem:

Found no assembler
Minimum version is nasm-2.13
If you really want to compile without asm, configure with --disable-asm.
make: *** [Makefile:109: dep/lib/libx264.a] Error 1

Is there a specific location where i should install nasm?

edit: OS Win 10/64 / MSYS2 64

I have only built this on a mac but I am assuming NASM needs to be on your PATH in windows.

1 Like
pacman -Su nasm 

should work…


This did work.

But thanks both of you!

However now i am getting a different error:

cd ffmpeg && PKG_CONFIG_PATH="/d/PRGMZ/UTILZ/RackSDK/plugins/VCV-Recorder/dep/lib/pkgconfig" ./configure --prefix="/d/PRGMZ/UTILZ/RackSDK/plugins/VCV-Recorder/dep" --enable-pic --enable-gpl \
        --disable-programs --disable-doc --disable-avdevice --disable-swresample --disable-postproc --disable-avfilter --disable-network --disable-iconv --disable-alsa --disable-autodetect --disable-everything \
        --enable-protocol=file \
        --enable-muxer=wav --enable-encoder=pcm_s16le --enable-encoder=pcm_s24le --enable-muxer=aiff --enable-encoder=pcm_s16be --enable-encoder=pcm_s24be --enable-libmp3lame --enable-muxer=mp3 --enable-encoder=libmp3lame --enable-muxer=flac --enable-encoder=flac --enable-muxer=ipod --enable-encoder=alac --enable-muxer=mpeg1system --enable-encoder=mpeg2video --enable-encoder=mp2 --enable-muxer=avi --enable-encoder=huffyuv --enable-muxer=avi --enable-encoder=ffv1 --enable-libx264 --enable-muxer=mp4 --enable-encoder=libx264 --enable-encoder=aac
/bin/sh: ./configure: No such file or directory
make: *** [Makefile:74: dep/lib/libavcodec.a] Error 127

Probably the ffmpeg submodule isn’t initialized. Run git submodule update --init --recursive. See https://vcvrack.com/manual/Building#building-rack-plugins

1 Like

Thanks a lot, that helped.

All steps went well now! All goodies added to VCV-Recorder :+1:t4: