Voxglitch Grooveboox broken on M1 Mac

I love the concept behind the Voxglitch groove box but it doesn’t seem to run correctly on an M1 MacBook Mini running BigSur 11.6.6. The option of Shift Control scroll wheel doesn’t let me navigate the sample folder just moves the rack view and instantiating the delay just makes the audio output module go full signal and then stops working, disconnecting the audio input still leaves 1 channel on full scale but still outputs no sound. It doesn’t crash the rack but I have to abandon the session and start a new one. Everything else I have tried in VCV rack runs flawlessly so far so it is not a problem with my system. I can live without using the delay but not been able to navigate my drum folders makes the device unusable. If it makes any difference my drum samples are located on an external ssd drive.

did you try shift-command (the mac equivalent)?

Cheers replying man, love your modules by the way, yes I tried all combinations of the modifier keys and still no luck.

Hi @lawnland ,

My apologies, but you need to hold down both CONTROL and SHIFT while using the scroll wheel. I know it seems ridiculous, but it was a necessary adjustment to ensure that users didn’t accidentally change their assigned samples while scrolling around in Rack.

Other ways of selecting files are:

  1. By double clicking on a slot
  2. By using the context menu

Concerning the delay, can you step me through how to reproduce that error? Is your DLY FBK at 100%? (If it is, that could cause chaos.)

OH! Also, welcome to the forums!!


Cheers for getting back to me man. Yes I tried holding them both together as I used the scroll wheel but still no no joy. I don’t suppose it could be the size of the folder thats causing the problem, over my many years as a producer I have amassed quite a large number of drum samples, for instance my kick drum folder has over a thousand samples. As for the delay problem my starting setup was quite basic with only an Impromptu Clock set to x32 ,the groove box itself and an audio output module. I haven’t had a chance to retry yet but I doubt the default for feedback is set to 100, if that is the default then that could be the reason. i’ll have another look later and report back. I’d just like to say that these are my first posts on the forum and the responses make me feel that the VCV rack community is a very responsive one and worthy of been a member. Thank you again for your timely reply

It’s my pleasure!

Concerning the scroll wheel

Quick question: Did you first load a sample into the sample slot before attempting to scroll? That’s necessary because the Groovebox stores the folder that was used and references that folder when scrolling. It’s unlikely that the number of samples in the folder would make a difference.

About the feedback

The default feedback is .5, so that doesn’t sound like the problem.


  1. Could you step me through the process of recreating this issue?
  2. What sample rate are you using?
  3. Could you turn on the performance meetings and see what it says? Mine looks like this:

I really appreciate your help!


Cheers I’ll try it later I am in a bit of a shock at the moment as we just heard the news that our Queen , Queen Elizabeth the II has just died

1 Like

Welcome to the community. It is good to see another of simillar … maturity to me.

Just had a quick chance to try it. I still cannot get the samples to load from a folder and I have tried every combination of Shift and Modifier keys held together whilst moving the scroll wheel. I also tried with a smaller sample folder with only 15 samples in case that was causing the problem. I tried different sample rates and even a couple of different clocks but still no luck. As to the other problem as soon as I move the delay level control only a small amount the Audio Modules Vu meters shoot up to full scale and the output is muted, only starting a new rack clears the problem. As for the performance meters the clock and output modules are at 0.1% each and the Groovebox at 4.1%. I wonder if its something to do with the Rosetta emulation although I doubt that as every other module I’ve tried ( so far ) has worked brilliantly.

Have you exited Rack and check the log to make sure Rack did not crash? I have seen Rack crashes that are “silent”.

Would there be any chance that you could create a movie that shows the delay issue? I’m hoping to repeat the process exactly on my machine to see if I get the same behavior. I appreciate that you’re helping me get to the bottom of it!

No there was no crash log file created but there was a file called ims.log that was generated, it was 86 bytes and an alias file. Also a file called DiscRecording.log was also created. It’s amazing that once you go behind the front veneer of macOS you start finding files that I used to have to deal with in Unix on old IBM computers in the 70’s. Thanks for your input man. Thats me done for today time to roll a number and chill for the rest of the evening been a pretty emotional day for all of us here in the UK

1 Like

no, the log.txt file in Rack’s user folder right after exiting Rack when issue happens (gets overwritten next start of Rack). Also check Crashreporter (MacOS Utilkity) for Rack crash reports, if indeed it did crash.

Cheers for that I didn’t know that VCV Rack kept a separate crash log , I was looking for crash reports in the macOS Library directory. I shall create the patch again and check later today, I shall also look at Crashreporter and see if anything turns up there. Thanks for your input.

Rack creates the log file each time you launch Rack. If all goes well and there is no crash, on exit the log file last line will say “END”. if END is not present, that means Rack crashed. and the log file may have a crash report at the end. The next time you start Rack, Rack reads the log file and clears it. if END is not present, it tells you there was a crash and asks you whether you want to create a new patch file. If you answer No, Rack will load your crashed patch from the autosave file. The key thing is that you must look at the log file after exit before restarting Rack as Rack will clear the log file before even letting you know there is a crash.

Yes I’ll give that a try later. What is the best method to do that as I have not done it before. Can I just use the included VCV recorder module. Out of interest what format does the VCV recorder use.

On Windows.

Another day another dollar, aren’t computers funny things, I’m sure they have a mind of their own sometimes. Recreated the same patch I did at least 10 times yesterday and had the delay issue every time and today it worked perfectly. The only thing I changed yesterday after which I didn’t try again as it was getting late was I cleared out all the log files in the library folder. I was a missile guidance engineer not a programmer so have no clue if that had anything to do with it all. Now I have had a chance to use it a bit I’m impressed ,you can even have different delay times on different steps which is cool. I also had a kick that was a bit long and boomy so I thought I try the end parameter and blow me down a waveform display popped up. Thanks to every one who chimed in all your help was appreciated. If now I could only work out how to get the scroll wheel sample select working all would be hunky dory.

That’s great news! If it’s any consolation, I’m probably going to redesign the sample selection functionality. It might take a while, but it should solve the problem if we can’t figure it out. :slight_smile:

1 Like

I told you computers were funny things lol, I just turned my computer back recreated the patch again and the problem is back. Everything works fine except for the delay. Every time I touch any control associated with delay I get a signal which overloads the output module and causes it output no sound. Sometimes returning the control ( any of them to do with delay ) back to default the output comes back and sometimes it seems to trip something in the output module and only deleting and reloading the output module resets it. I tried looking at the signal on the scope and it seems that when I touch a delay control the groove box outputs a large negative pulse that seems to be at the tempo of the clock. I’ve had to leave it for a bit to have a snack but I’ve got a few ideas yet to try and I’ll let you know what I find out. I haven’t managed to do a video yet, as been quite honest I don’t know the best way to do it, Perhaps if someone would like to let me how to do it any help would be appreciated , however the patch is identical to the one in your screenshot. I’m quite enjoying this having to use my brain in a technical way rather than a musical one reminds of being back at work, which I miss.