VCVRack to my system audio

PROGRESS! I did file > new but still no AUDIO-nn modules.

I began to suspect something wrong in my launch logistics.

Instead of a desktop launcher, I navigated to the installation directory “/opt/VCV-Rack/Rack”, and issued the command

jim@host_A:/opt/VCV-Rack/Rack$ ./Rack

When I right-clicked my mouse I got the full offering of 33 modules, including AUDIO-8 and AUDIO-16.

Thanks for your help. I expect that by the end of the day I should be able to report my ears being tickled.

1 Like

You can create or edit a desktop file to be like this:

[Desktop Entry]

Save that in ~/.local/share/applications/ as vcvrack.desktop. You will need to change the locations to your own.


OK, so the audio module is finally installed, and connected as shown in the image. Still no sound, so I’m also uploading some logging info from qjackctl. Thanks for spending all this time with a noob like me.

OOPS here’s the uploads I mentioned…


Show the qjacktcl connections window.
Also what is plugged in to the mixer? Doesn’t look like anything is passing through it.

Your jack log is ok but it looks like you’re not running a lowlatency kernel or haven’t set something up somewhere, run the quickscan I linked above and it will tell you. Post the output here in fact.

The MIXER IN1 signal is coming from the VCF LPF out, in a conventional VCO->VCF path governed by an ADSR gated from LFO-2. (At least I hope that’s what’s happening… 8^) seriously, it would be hard to believe I’d committed any patching errors as basic as that.)

I’ve attached the output of a real… Looks like a neat tool I’ll come back to more than once.

I think this is the connections window you asked for… .

Install lowlatency or liquorix kernel and add yourself to the audio group. those are the things causing errors in the jack log.

I think it should work as it is but do those two things first.

Maybe just send an oscillator out on its own, least you know it should be making sound then.

Ok, make the adjustments and reboot, start jack, vcv and then post that again.

@jamzen to make all the process more easy, take a look of this step by step guide to setup your Audio environment in Linux

Linux Audio Survival Kid


We have ignition. As of yesterday afternoon. I followed David’s link to the “Linux Audio Survival Kit”. With a little more fiddling, started to hear things from VCV-Rack.

Naturally there are a bunch of lessons for me in reflecting on the path I took through the past 4-5 days. I should have begun with a couple of hours of youtube video clips on the subject. Instead, I wasted a good deal of time – mine and yours – thrashing around in my own ignorance.

Anyway, I guess I’m ready for the next phase. Thanks to everybody who contributed here.

“Next phase” = detailed examination of each module, with notes on its behavior, and how that behavior differs from that of an equivalent analog function.

1 Like

glad of help
enjoy the vcv rack experience

btw SKjack is now available in the V1

1 Like

Oops: my audio connections are still behaving erratically.

I’m seeing a red vertical bar on the left side of AUDIO-8, and a sky-high cpu usage.

This persists even when I ctl-E disable all the other eight modules.

There’s something I’m still not getting about JACK connections. I’m uploading a couple of screenshots.

The audio was fine. No problem. But I figure that if the 90% load remains with all the audio processors disabled, it must originate in something funny in the Jack patching.


It’s NOT what you\re using, it’s what you have left.

I’ll experiment with specifying 4 or 6 or 8 threads, instead of just one. Reading about “CPU timer” suggests that I was overreacting to the red bar and the 90% usage value.

The red bar on the Audio module is the percentage you have left to work with measured in ms. The red bar on each module is how much it’s using. A lot of people misunderstood this to begin with.

It doesn’t help that it’s an angry red colour. If the one on Audio was green, that might be better.

(Goes and scribbles on GitHub.)


use only one until you need more , but before assign a new threads try to wake up the first one with

echo performance | sudo tee /sys/devices/system/cpu/cpu*/cpufreq/scaling_governor

Why does the survival kit currently suggest to build Rack from sources rather than downloading the binary? Are there any practical advantages? (or is it just not up-to-date?)

hola mixer!

it is a kind of random tutorial for new linux users, I started installing repositories, then, software from the repo, for a downloaded .deb, a .sh from the command line, and finally compiling, but it could have beed how to compile a Zynaddsubfx, or a vcv rack plugging.

but there are some reason to compile a software by yourself,for instance, you can have and try the last version of the software (at this point it is not necessary since the v1 have no new release ), or to make the software perfectly fit to your hardware or to enable an special feature, like jack in the v0.5 and so on.

I will rewrite these, I should do for the v2, for now the leonardo’s guide is the best