VCVRack to my system audio

Haven’t made it happen yet. Mint 19.1 on an ASUS Sabertooth 990FX w/ 32GB. Up to now the only audio on here has been from the media player – some *.flac files – and concert music on Youtube.

I know linux well and have background in audio synthesis (long ago) and 20 years in software engineering. JACK is evidently present on my machine; qjackctl runs, but doesn’t find anything to connect to, in or out. The audio hardware is just whatever’s on the motherboard.

I’ve made small changes to the initial VCV-Rack patch, and observed their consequences on the scope (added an LFO to provide gates to the ADSR, noodled with the a.d.s.r. parameters to confirm they work the same way they did forty years ago, and so on).

I tried installing the skjack plugin. But nothing came of that – I couldn’t confirm it had even been downloaded – didn’t find any evidence in ~/res or in ~/.Rack.


you need to fix jack/qjackctl and make it connect with your audio system, which i’m assuming is alsa. if you have pulseaudio running as well, disable it, since it is unlikely to add anything useful and is just another point of failure. jack can do a much better job, in combination with alsa.

1 Like

Alsa is there alright, but so is pulseaudio, and it won’t quit. I considered deleting it altogether, but synaptic told me that would get rid of cinnamon as well. Cinnamon is my desktop manager; I’m not quite ready to abandon that. (Well, I will if I have to but I’m not quite there yet.)

I tried just killing the pulseaudio process, but in less than three seconds it restarted. I’m hazy on the systemd logistics for managing processes – I guess I’ll take a look at that tomorrow.

Of course, if Mint has integrated pulseaudio into its own audio infrastructure, there may be effectively nothing I can do about this situation. In that event I’d happily install something in one of my VirtualBox machines just for the experience… .

Anybody else got any advice? I’ll report tomorrow on any progress I make.

this may help

can we have a capture of your core audio module and the pachtbay?

There’s no need to disable or uninstall pulseaudio, you’re just setting yourself up for more problems later on if you do that. Make sure you have the pulseaudio jack module installed and it should bridge to jack automatically.

Did you set the card for in and out in qjackctl?

agreed, you can still using pulse audio (or not ) and that could not be a problem , as @TroubledMind said you should set your system to use Jack

SKjack is not available to the V1

Uh – is this what you meant?

It certainly did. Pulseaudio is now disabled. So we’re down to just making a connection between VCV-Rack and my system audio output.

Can you show the Connect screen when you have vcv running?

it was running when I took the screenshot. I had actually succeeded in connecting an input to an output port. I got some sound out of my speakers, but it turned out to be a feedback loop. Nothing to do with the sequence of audio events I had set up on vcv. One momentary jolt of adrenalin followed by a moment of severe depression… .

I keep staring at the empty “mix” socket on the VCV mixer module, where the audio output is probably happening. Should I be fiddling with “alsamixer” as well as qjackctl? I fooled around with that earlier today, trying to make something happen.

Ah – I looked at recent messages – here’s a screenshot:

Did you run this already?

Looks like there are a few issues that can be sorted with that. Linuxaudio wiki also has loads of tips, you need to edit the limits.conf. Don’t worry too much about the kernel, install the lowlatency kernel if you can but not the end of the world if not.

Is is rack definitely set to output to jack? I’ve seen some people choose jack in Audio and not realise that there is a secondary selection.

Otherwise, yes check alsamixer. It is common that it is muted by default. Look for any that have mm under the fader.

1 Like

no, the core audio that show which audio driver are you using and which device is connected

and the way how is it conected

I remember being bitten by this stupid… feature so many times when running Linux. Run


from the terminal and un-mute/raise the master levels.

1 Like

the auto mute feature (to turn off the front output when headphones are connected) is a bitch too.

1 Like

Huh. I just learned of the existence of this module (the “core audio”) yesterday. But I haven’t been able to find any instance of it in my running VCV-Rack.

Sure looks as if this could – and should – cure my system’s silence. But how on earth am I supposed to get access to it?

Yeah, I fooled around with amixer/alsamixer a few days back. Just enough to raise/lower mute/unmute a few channels, and file the whole business away for attention later, after I’ve started to actually hear things from my loudspeakers.


add A core audio module to your patch, then select in the driver section JACK

then in the audio device section select your hardware , and finally using QjackCtl (or your LADISH) make the connections between the rack and your hardware

Done, you have audio from the rack

edited: sorry the actual name (v1) is Audio-8

in version 1: right-click to get the module browser, then scroll down in brands to vcv, click that, and then select audio-8 or audio-16.