VCV with BeatStep Pro: MIDI out not working

I’m trying to connect the BeatStep Pro with VCV Rack. I’ve got a small USB MIDI interface between them.

In VCV Rack, the CV > MIDI module is working great: I’ve got CV, Gate, and Velocity data going out of VCV Rack and into the BeatStep Pro.

But the MIDI > CV module isn’t working. I’m trying to get Clock data from the BeatStep Pro to VCV Rack, but there’s nothing coming out of the Clk output on the module.

Here’s a screenshot — you can see from the lit-up ports that there’s two channels of data coming out of Orca’s Heart into the CV > MIDI module, but nothing coming out of the Clk module.

The BeatStep Pro is set to Int (i.e. internal clock mode) and the transport is playing, and the Tap Tempo button is flashing in time, indicating that the clock is active.

Any suggestions?

I think you need at least an AUDIO 2, 8 or 16 in your patch to make this work.

And choose the right device.

1 Like

Hmm … I added an Audio 2 and set the device to my computer speakers and it doesn’t have any effect on the MIDI > CV device.

Does this help in any way ?

I haven’t used it much, but clock in from BSP seems to work for me.

I used Arturia Midi Control center to set “24 ppq” In device settingssyncclock in/out settings. Use the “-MODE+” buttons on CLOCKED to set it to “P24” to match.

You have to close Midi control center before connecting to the device in vcv rack they cannot share the connection. (In windows - don’t know about other platforms)

1 Like

Ah, that helped me see where I was going wrong. For some reason I was trying to use the MIDI in/out on the BSP, with a USB-MIDI adaptor, because I forgot that the BSP could send MIDI through the USB port. Once I got rid of that intermediate device and just connected the BSP directly to the computer, everything worked fine. (I still don’t know why it wasn’t working with the MIDI adaptor but eh who cares.)

Thanks for the tip on setting the Clocked mode, that would have been the next hurdle for me!

Also I was curious whether VCV Rack actually needs an audio module for this usage (where I’m not actually sending any audio out of VCV Rack), so I deleted the audio device and it continued to work fine.