VCV Rack site certificate had expired, now fixed.

So the SSL cert for vcvrack.com seems to have expired today. The github action uses curl to download the rack sdk, but it is reporting the cert has expired. I can tell curl to ignore the expired cert but that seems less than ideal long-term.

2 Likes

That’s affecting log in from within Rack.

[4.069 info src/network.cpp:147 requestJson] Requesting JSON GET https://api.vcvrack.com/version?edition=Pro
[4.307 warn src/network.cpp:157 requestJson] Could not request https://api.vcvrack.com/version?edition=Pro: SSL peer certificate or SSH remote key was not OK
[4.307 warn src/library.cpp:74 checkAppUpdate] Request for version failed
1 Like

Yes. I’m getting a warning in Chrome about the cert and the page style of the Rack homepage was like a flashback to a 1993 Mosaic page.

Where’s the scrolling banner?

We’re aware of it and are looking into it.

6 Likes

Can’t log in and VCV Rack says “Could not query user account”

I’ve used my password and still no luck, it worked fine yesterday not today can’t log in…

LetsEncrypt auto-renew scripts are a PITA. That’s why these days I put everything behind Traefik and let it take care of bi-monthly auto-renew for me (and handle best-practice SSL configurations etc.).

The first scrolling banners I remember were when we got a copy of a Java IDE named Visual Cafe at work in 1996, adding a scrolling text banner was one of the code examples. I’m sure loads did it before then but maybe I’ve managed to erase them from my mind, gone, like so many BLINK tags in the rain.