VCV Rack plugin not showing in Bitwig

I just purchased VCV Rack so that I can use any of VST/VST3/Clap in Bitwig. I’m running latest Manjaro XFCE. I’ve downloaded the VCV 2.3.0 zip from the site and followed the INSTALL.txt instructions to copy the various plugins to their locations i.e. ~/.vst. One surprise I found is that the VST3 contains no files in its directory. But I did copy the VST .so and .clap to where they should be.

Bitwig 4.4.10 is configured to look in these directories but the VCV plugin does not show up. I’ve tried restarting and rebooting, updating plugin indexes. Nothing.

Am I doing something wrong?

In Bitwig Plug-ins section there is a button at the bottom to ‘Show plug-in errors’ which listed the VCV plugins. Rescanning did not fix. From the ‘Copy errors to clipboard’:

/home/REDACTED/.clap/VCV Rack 2.clap

com.bitwig.flt.library.metadata.reader.exception.CouldNotReadMetadataException: could not read metadata: Failed to initialized CLAP plug-in /home/REDACTED/.clap/VCV Rack 2.clap: clap_plugin_entry->init() returned false

/usr/lib/vst/VCV Rack 2

com.bitwig.flt.library.metadata.reader.exception.CouldNotReadMetadataException: could not read metadata: createAEffectInstance returned NULL

/usr/lib/vst/VCV Rack

com.bitwig.flt.library.metadata.reader.exception.CouldNotReadMetadataException: could not read metadata: createAEffectInstance returned NULL

See this discussion.

Thanks for that link. In particular this comment covers a dependency that might be the culprit: VCV VST and Bitwig - #11 by falkTX I’m not willing to downgrade a system library to get VCV working since it risks causing other issues.

I tried the OP’s suggestion to put the .so in a subdir, cleared Bitwig caches, but still the same ‘could not read metadata’ issue.

I tried out Bitwig 5 Beta 10. It gets the same errors from VCV plugins.

VCV support here > VCV - Support

I’m not sure why but when I unzipped the VCV download again I discovered that the VST3 directory contained an .so this time. Very strange, I’m sure I didn’t move or remove that before.

When placing the VST3 directory into ~/.vst3, now Bitwig detects VCV, but if I try to use the plugin at all it shows ‘Plugin host died: Could not read async reply: End of stream’. Both Bitwig 4 and 5 Beta. Same after clearing index and vst metadata from cache. I removed the ~/.Rack2/plugins directory. No change. I moved ~/.Rack2 to ~/.Rack2Off. No change. I tried opening VCV in Standalone and removing the default initial modules to an empty canvas and closing. No change in Bitwig.

The comment above was a friendly suggestion that you likely to get better support through the official channels, rather than on this enthusiast community site.

I understand. I’ve emailed VCV support.

1 Like

I’m the OP of the thread linked above. Still the same for me, I think the problem is unfixable unless you are willing to go back to a considerably older version of your distro. I use Cardinal as a vst in Bitwig which works fine.

Got busy and forgot to check this. For what it is worth, I am still able to use Rack Pro version 2.0.6 as a VST with Bitwig 4.4.10 and Ubuntu Studio 22.04. Every version of Rack Pro after that I have tried fails.

The fact that Cardinal works fine and Rack Pro, which I paid a not insignificant amount of money for, does not work fine is kinda disappointing.

did you email

Hi everyone. I want to follow up here that I’ve gone back and forth with VCV support and am happy to say that I’ve managed to get VCV plugins to work in Bitwig 4.4.10. The short of what was causing my problems: I was trying to use the plugins which I had purchased and downloaded from alongside using vcvrack-bin from the AUR which is (understandably) just the free VCV Rack version. The plugins are NOT compatible with the free version. You must use the VCV Rack Pro version you download along with the plugins, and it must either be placed in one of the directories specified in the INSTALL.txt (in my case, I copied the Rack2Pro directory to /usr/share/VCV/Rack2Pro) or specify a RACK_SYSTEM_DIR that points to where your Rack2Pro directory is.

Once I had done this, any of the VST/VST3/Clap versions all now work properly for me in Bitwig. VST and Clap versions now show, and the VST3 plugin’s error of ‘Plugin host died: Could not read async reply: End of stream’ no longer occurs. It should report something much more relevant, and the VCV team is aware of this suggestion.

I’m curious if this is the root issue for you @melondruie and @darkstar01uk ? I ultimately did not need to downgrade system dependencies at all (on the latest Manjaro XFCE and kernel 6.3.5-2)


Hi @tobblestop good to hear you have got Pro working in Bitwig. I’ve just checked, re-installed Rack Pro in the directories mentioned in INSTALL.txt but no change - the vst2 and Clap versions report an error in Plug-in scan in Bitwig, vst3 appears in the plug-in list but crashes with the “async” message. Ubuntu 22.04 up to date, Bitwig 4.4.6, Rack 2.3.0.

If you delete your Rack log file, reproduce the Bitwig problem for the VST2, and close Bitwig, do you get a log file? And same question for the VST3 (asking separately because you’re seeing different symptoms).

I checked to make sure that I had the Pro version installed and not the Free version and I do have the Pro version. Both Clap and VST3 crash with the async error message.

When checking things on my system, I realized the 2.0.6 version that is working for me is a VST2 plugin and not VST3. Not sure if this is helpful information or not.