VCV Rack and Doepfer Ribbon to MIDI controller

Hello! I am quite new to VCV and modular synthesis in general, and I recently set up a Doepfer Ribbon to MIDI controller as my choice of external hardware. To make this connection, I am using a converter cable which translates the older 5-pin midi ports to the computer. I am able to use the ribbon controller to control VCV Rack but randomly while playing I’ll get an audio output as if I was holding down a note when I have released my finger from the controller. This output is usually much lower in pitch than what I have the controller set to play, but can also drone on notes that are in the range. Subsequent presses on the controller will play the correct pitch but after I release my finder again, the drone of the random note continues. I don’t have any trouble using a QWERTY keyboard or modern usb piano keyboard which leads me to believe the ribbon controller is messing something up along the way. What might be the problem and/or do ribbon controllers work with VCV?

Have you tried the RIbbon controller with other Software synths ? Does it behave the same ?

Yes as suggested definitely try it with other software You could for example try recording the midi data from the ribbon cable into a DAW to check what it is actually outputting , and I would also suggest that you test the converter cable if possible , does your usb keyboard also have a midi din output on it at all .

mine works properly, with an ES-9.

does it happen with the hold switch set to ON or OFF on the module?

btw, if you have understood what the hold switch does, I think you have a faulty unit…another option could be in your interface of course…you should try it with an analog synth, without the interface

On which module?

I have tried it with Musescore and noticed no faults, but that testing was limited

Another interesting behavior is that it worked fine on my laptop for about a day, and then the issue arose again. I’m really unsure if it is a hardware or software but I can test more and report back what I find, thanks for the help!

I don’t have a DAW/I am not sure how to go about recording the MIDI data, and I am also not sure about the MIDI din output either, I’m not familiar with what that is or maybe I am misreading your post.

I don’t own a doepfer ribbon controller, But I found the manual here:

http://www.doepfer.de/pdf/R2M_man.pdf

Perhaps the R2M is set to translate the pressure sensor data to MIDI pitch/note value ?

I suggest starting out by simply sending midi note data corresponding to position, and adding pitch bend after you have that working (page 23 in the R2M manual)

Midi to CV + Pitch bend - perhaps a userfriendly module exists - i haven’t found it - but i just ordered an AKAI EWI usb, so I will be looking for one… Some tips:

Hi again , ok regarding the midi din confusion you mentioned that you had a modern usb piano which I took to be a controller keyboard which you said worked fine , I was wondering that if the keyboard had both usb plus the older style midi outputs then you could connect the keyboard via converter cable to the PC to check for errant behaviour with regards to the cable . As for recording Midi data via a DAW I would suggest downloading Reaper which is free for evaluation purposes and simple to set up for both audio and midi devices (plenty of online tutorials on YouTube) then insert and arm a track in Reaper with the Doepher ribbon as midi input, hit record and play the Doepher. In a further post you also mentioned that the ribbon controller worked as expected then problems arose again later so as a further suggestion I would also check every connection in the chain. Whilst playing the Doepher then gently move all the connections to make sure they are not intermittently connecting and disconnecting somehow , check the ribbon cable connection into the Doepher , then check the Doepher connection to the converter cable and finally check the converter cable input to the computer. It could be that as you are playing slight movement of a cable is causing the errant behaviour .

on the doepfer A-198 module