VCV Rack 2 Free closes when I save any patch (Linux Mint + wine)


I run VCV Rack Free 2.4.1 using the wine utility:

wine ~/.wine/drive_c/Program\ Files/VCV/Rack2Free/Rack.exe

It works fine, I even downloaded all the plugins from my account. But when I try to save a patch or overwrite a template patch, VCV Rack closes without errors. I also don’t see any errors in the log file:

cat ~/.wine/drive_c/users/matvey/My\ Documents/Rack2/log.txt

Could you please tell me what the problem might be? Thanks!


Can you use Linux version of VCV Rack v2.4.1, instead of Windows version over wine? (my question here is probably stupid).

I can’t help - I’m using Linux (Ubuntu - running inside VMware virtual machine) only to compile mine plugins (by using VCV Rack Plugin Toolchain), nothing else.

Good luck.


Definitely use the linux version of Rack, I can’t imagine why you would want to run it in wine.


I don’t run Rack Linux version because vst or vst3 plugins don’t open in “host” / “host fx” racks ( But when I open Rack using wine - vst plugins work.

Have you tried yabridge? That would be a much better solution than running the whole of rack in wine. You will be able to use the VSTs in other daws/hosts as well then.


libarchive used by VCV Rack has some not-so-correct usage of Windows APIs that Wine does not expect, leading to crashes. (from what I understood some tar archive entries have invalid paths, which real Windows casually ignores but Wine does not)

had to deal with the same for Cardinal, being Rack code after all, and put a workaround for it in
unless you build Rack yourself I don’t think you can workaround this.


Why run under wine? There’s a native linux Rack.

1 Like

I just tried yabridgectl and now all my vst plugins open without problems on Linux! Thank you so much!