vcv plugin - weird behaviour in reaper


I’m having this issue when running VCV as a plugin in Reaper: midi messages from daw to vcv only works when te daw transport is active. When daw stops, vcv doesn’t get any midi. In Ableton everything works fine and also in others VSTs in Reaper. Anyone else experience this? Any hint to solve?


@Omri_Cohen uses it in Reaper, perhaps he has experienced this and can help…

1 Like


An add to issue. When there’s a MIDI item in the track then the messages are passed to VCV with transport stopped. I’m probably missing something obvious here…


I’m not so sure I understand the issue. Do you mean that when Reaper is not running, then the Midi will not go to VCV? Isn’t this the expected behavior? As Lars mentioned, I’m also using Reaper so let me know how to reproduce the issue and I will give it a try :slight_smile:

Hi, Omri, thanks for answer.

The issue is about live MIDI, not MIDI item. I’m using a controller to play notes, nothing complicated, just midi notes to Rings and audio out, for example. No sequencers or clocks involved. It works only when Reaper is running. It’s happening only with VCV and only in Reaper. Other VSTs in Reaper works fine, VCV in other hosts works fine.

I just tried it and it works as expected so no need for Reaper to run. I have the Keystep connected and it’s playing Rings inside VCV with the Midi module set to DAW, and the audio goes back to Reaper. How do you have it set up? Can you share a screenshot?

works fine for me too.

Very basic setup, in fact. Here’s a screen capture showing the issue. Looks very weird to me.

Used to work here, but last week it suddenly changed and I couldn’t find the cause. I checked all the audio and midi settings looking for any changes I could have made, but I didn’t find anything different.

what happens if you constrain your MIDI controller to channel 1 and select channel 1 rather than ‘all channels’ on the MIDI->CV module?

Edit: also check Polyphony by right clicking on the MIDI->CV menu. If you set 16 voice polyphony and only play a note at a time it’ll take 16 key presses to hear one sound on the default ‘Rotate’ mode. Still not sure how it’d work OK when ‘running’ the DAW then though. Try choosing Polyphony Channels > Monophonic. Still hear nothing then?

Thank you for your suggestions. I tried but it didn’t change the behavior. On the other hand, I think I found the issue. It is related to the cursor position in the project. I use to have my projects start at measure 0 instead of 1. It seems that the VCV takes the cursor position into account and doesn’t accept MIDI if it’s before bar 1, even with the transport stopped. Is there a way to change this setting?

I didn’t even know you could set Reaper to start on bar 0, so I learned something. Since using various DAWs over the years I usually start recording at Bar 9 :slight_smile:

Something else must be going on. Reaper and VCV work as expected for me @ bar 0, transport running or not.