VCV AUDIO module changes "Sample Rate" and "Block Size" on me

I like to keep the block size at 1024, and the sample rate at 44.1 kHz. This is what I use in my template patch.

Whenever I change the “Audio device” setting (say, from “External headphones” to “(No device)” or anything else), the Block size defaults to 256 and the Sample rate jumps to 48 kHz. Changing it back does not revert to my original settings either.

Is there any compelling reason why Rack does this?

It does at least remember settings in saved patches.

Hey, yo, Maybe in the engine option you can change the default sample rate? I have it on auto and it changes the sample rate depending on the speaker I’m using. And depending on which one is on it requieres a different sample rate, so maybe that’s why VCV rack does it.

My device keeps switching itself to 48k. Might just let everyone go to 48…