VCV 1.1.6 crashes on Arch Linux

Binary downloaded from both web site and Arch User Repository got the same crash log.

[0.000 info src/main.cpp:119] VCV Rack v1.1.6
[0.000 info src/main.cpp:120] Linux 5.6.6-arch1-1 #1 SMP PREEMPT Tue, 21 Apr 2020 10:35:16 +0000 x86_64
[0.000 info src/main.cpp:126] Args: /home/idoleat/Music/Rack-1.1.6-lin/Rack/Rack 
[0.000 info src/main.cpp:129] System directory: .
[0.000 info src/main.cpp:130] User directory: /home/idoleat/.Rack
[0.000 info src/settings.cpp:206] Loading settings /home/idoleat/.Rack/settings-v1.json
[0.000 info src/main.cpp:155] Initializing environment
[0.008 fatal src/main.cpp:45] Fatal signal 6. Stack trace:
15: /home/idoleat/Music/Rack-1.1.6-lin/Rack/Rack() [0x56d2b1]
14: /usr/lib/libc.so.6(+0x3bd70) [0x7f8e3c88bd70]
13: /usr/lib/libc.so.6(gsignal+0x145) [0x7f8e3c88bce5]
12: /usr/lib/libc.so.6(abort+0x12b) [0x7f8e3c875857]
11: /usr/lib/libstdc++.so.6(+0x9681d) [0x7f8e3cc0e81d]
10: /usr/lib/libstdc++.so.6(+0xa32ca) [0x7f8e3cc1b2ca]
9: /usr/lib/libstdc++.so.6(+0xa3337) [0x7f8e3cc1b337]
8: /usr/lib/libstdc++.so.6(+0xa359e) [0x7f8e3cc1b59e]
7: /home/idoleat/Music/Rack-1.1.6-lin/Rack/Rack(_ZN7MidiApi5errorEN11RtMidiError4TypeENSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE+0x151) [0x8219d7]
6: /home/idoleat/Music/Rack-1.1.6-lin/Rack/Rack(_ZN10MidiInAlsa10initializeERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEE+0x255) [0x821ce9]
5: /home/idoleat/Music/Rack-1.1.6-lin/Rack/Rack(_ZN8RtMidiIn11openMidiApiEN6RtMidi3ApiERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEj+0x6c) [0x8264f0]
4: /home/idoleat/Music/Rack-1.1.6-lin/Rack/Rack(_ZN8RtMidiInC1EN6RtMidi3ApiERKNSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEEj+0x3f) [0x8265f9]
3: /home/idoleat/Music/Rack-1.1.6-lin/Rack/Rack(_ZN4rack10rtmidiInitEv+0x153) [0x540c43]
2: /home/idoleat/Music/Rack-1.1.6-lin/Rack/Rack(main+0x33b) [0x4e618b]
1: /usr/lib/libc.so.6(__libc_start_main+0xf3) [0x7f8e3c877023]
0: /home/idoleat/Music/Rack-1.1.6-lin/Rack/Rack(_start+0x29) [0x4eb1f9]

Haven’t tried to compiled by myself yet.

Just tell me if you need any other info.

Appreciated in advanced for the help.

There’s a bug report for something very similar on GitHub, would be better for you to post there.

1 Like

I check again today and vcvrack works. I think it was some packages messed up the environment. Maybe the update yesterday fixed that.

Typical rolling update system problem…hmm…

I run on manjaro, and I also have this kind of issues with libstdc. In my case, it was always after an upgrade. After reboot, this issue disappears.