Vanilla patch that crashes VCV Rack 2

Hello, I’ve built a patch using only VCV modules + Macro Oscillator 2 that consistently crashes Rack 2! I think I’m gonna check if there is somewhere on github to submit it, but first I’ll share it here. Crash happens when you unmute channels on MUTES module.

vanilla_patch_that_crashes_rack2.vcv (2.7 KB)

Yes It closes Rack for me too, Win10.

here too, Win 11

Is it perhaps related to the 4->1 3rd input not being connected?

For what it’s worth, it works fine on my Mac.

No , just tried duplicating 4 to 3 and it still crashes.

It crushed for me after i pressed the logic Sidenote: It last longer on wasapi then sound direct

W10 ASIO, also crashes, I’ve noticed that it crashes when I unmute the last of the 4 mute buttons- no matter of the order i do it …

has anyone filed a bug via support@vcvrack.com? If not, please do so stat. with all bits of info and possible repro steps and the various configs etc. I also cannot repro it on my M<ac, so definitely a windows thing by the looks of it (any linux tester yet to confirm whether that also is fine or crashes?

I can confirm that it also crashes on Linux (Mint 20.2 & PulseAudio), when I unmute all 4 mute buttons. Edit: also crashes when I select JACK in the audio driver, it only takes slightly longer to crash (5-30 seconds after unmuting the 4th button) compared to when I have PulseAudio selected in the audio driver (crashes immediately).

It crashes on Linux as well, but not right away. When I first load up the patch, and haven’t yet selected an output, the patch is “inactive”, and I can’t mute or unmute. I then select an output (either ALSA or PulseAudio in my case; I’m running on Pipewire). When selecting an output, either the first three, or all four “mutes” comes up as muted (this differs between runs, I don’t know why). I can then start muting and unmuting, and it will start playing. This can go on for quite some time (have been running for at least 5 minutes in one case), but eventually it will crash and dump core in the macro oscillator. This does not seem directly tied to muting or unmuting any particular “track”, but seems to be tied to, at one point, having unmuted the fourth (I can not be 100% sure of this though). If I then restart and reload the track (against the dialog recommendation), it will crash immediately. If I instead clear and load the patch fresh, the cycle starts again.

Nah, scratch that, I just got it to crash by just unmuting the first three tracks, so it does not seem to be directly related to any particular track.

No problems on Mac OS Monterey 12.6

Another observation: it doesn’t crash as long as I keep the 3rd button muted (the one that goes to the Plaits Morph Input), and it sometimes can take a while (after unmuting this 3rd button) before it crashes.

Crash after a few seconds after unmuting all of the channels.

Program terminated with signal SIGSEGV, Segmentation fault.
#0  0x00007fbb6e276cb0 in stmlib::InterpolateHermite (size=512, index=5.87365294e+10, table=<optimized out>) at ./eurorack/stmlib/dsp/dsp.h:56
56        const float x0 = table[index_integral + 0];
[Current thread is 1 (Thread 0x7fbb60bfe640 (LWP 544549))]
(gdb) bt
#0  0x00007fbb6e276cb0 in stmlib::InterpolateHermite (size=512, index=5.87365294e+10, table=<optimized out>) at ./eurorack/stmlib/dsp/dsp.h:56
#1  plaits::WaveshapingEngine::Render (this=0x560091c00c00, parameters=..., out=0x560091c00dc0, aux=0x560091c00e20, size=12, already_enveloped=<optimized out>) at eurorack/plaits/dsp/engine/waveshaping_engine.cc:125
#2  0x00007fbb6e265c28 in plaits::Voice::Render (this=this@entry=0x560091bffbc8, patch=..., modulations=..., frames=frames@entry=0x7fbb60bfd400, size=size@entry=12) at eurorack/plaits/dsp/voice.cc:199
#3  0x00007fbb6e20b4a2 in Plaits::process (this=0x560091bffa80, args=...) at src/Plaits.cpp:222
#4  0x00007fbb700e2d1a in rack::engine::Module::doProcess (this=0x560091bffa80, args=...) at src/engine/Module.cpp:345
#5  0x00007fbb700dd4c1 in rack::engine::Engine_stepWorker (that=0x56009145f500, that=0x56009145f500, threadId=0) at src/engine/Engine.cpp:323
#6  rack::engine::Engine_stepFrame (that=<optimized out>) at src/engine/Engine.cpp:395
#7  rack::engine::Engine::stepBlock (this=<optimized out>, frames=<optimized out>) at src/engine/Engine.cpp:551
#8  0x00007fbb70001f23 in rack::audio::Device::processBuffer (this=0x5600914b28b0, input=0x0, inputStride=0, output=0x560091a251e0, outputStride=2, frames=1024) at src/audio.cpp:45
#9  0x00007fbb70031446 in rack::RtAudioDevice::rtAudioCallback (outputBuffer=0x560091a251e0, inputBuffer=0x0, nFrames=1024, streamTime=<optimized out>, status=<optimized out>, userData=0x5600914b28b0) at src/rtaudio.cpp:213
#10 0x00007fbb704e3b1d in RtApiJack::callbackEvent (nframes=<optimized out>, this=0x560091a2cd70) at /home/cschol/src/Rack-2.0/dep/rtaudio/RtAudio.cpp:2758
#11 RtApiJack::callbackEvent (this=0x560091a2cd70, nframes=1024) at /home/cschol/src/Rack-2.0/dep/rtaudio/RtAudio.cpp:2716
#12 0x00007fbb704e3e45 in jackCallbackHandler (nframes=<optimized out>, infoPointer=<optimized out>) at /home/cschol/src/Rack-2.0/dep/rtaudio/RtAudio.cpp:2234
#13 0x00007fbb6f8efb0f in ?? () from /lib/x86_64-linux-gnu/libjack.so.0
#14 0x00007fbb6f8ef7d8 in ?? () from /lib/x86_64-linux-gnu/libjack.so.0
#15 0x00007fbb6f90c910 in ?? () from /lib/x86_64-linux-gnu/libjack.so.0
#16 0x00007fbb6fb4eb43 in start_thread (arg=<optimized out>) at ./nptl/pthread_create.c:442
#17 0x00007fbb6fbe0a00 in clone3 () at ../sysdeps/unix/sysv/linux/x86_64/clone3.S:81
2 Likes

Interesting, so it’s the Plaits DSP crashing then. Maybe there’s bugfixes upstream that needs incoorperating into Audible Instruments.

2 Likes

Maybe @hemmer can take a look ?

I’m on Mac unfortunately, can’t reproduce here (easily)

1 Like

it seems:
here it crashes only
when the macro oscillator 2 model “waveshaping oscillator” is choosen initially.
when I choose another model at start it doesn’t crash here.
But when I choose the waveshaping oscillator later it crashes again.

Please try to change the model first and then choose your audio driver/interface and see if it crashes still.

I tried that - no problems. I set Audio Driver to (no device) then set Plaits to Waveshaping Oscillator. When I selected an audio driver it ran with no problems. I went through all the voices on Plaits and still no problems.