User folder won't change

I have recently bought more storage for my computer (windows), and i want the rack modules to not be in the usual windows directory, and to go to my new drive instead. I have followed the command line tutorial but all it does is download the modules to the original and the new folder, but rack still thinks that the folder is the default directory.

Attach your log.txt after launching Rack.

This doesn’t make sense. You’re saying that it’s downloading plugins to both folders simultaneously?

Yep, it’s weird! they show up as zip in the new folder and normal in the old folder log.txt (15.1 KB) (not sure if this one is relevant, if it isn’t i’ll do the command line thing again)

One potential issue is that because “Rack Library” has a space in it, you should put it in quotes, Rack.exe -u "D:\Rack Library".

Could you delete both plugins-v1 folders and re-run to see what exactly is created upon syncing.

They’re only being sent to the new directory now, but they’re still all in zip for some reason. Edit: Rack has went back to the original folder again.

It works when I do the command now. Is there a way to turn the command into a shortcut?

The -u flag tells Rack where the user directory should be. If you run Rack without it, it will default to Documents/Rack/.

Yes, create a shortcut, open the shortcut’s Properties window, and add the command line arguments to the text field.

1 Like

Done! Thank you for your help!