upgraded to macOS Catalina, no more sound

Hello, I just downloaded VCV Rack less than 2 weeks ago and the default patch worked fine, then I upgraded my iMac to Catalina last weekend and since then I haven’t been able to get any sound, although I can see the curveforms in the spectrograph when I touch a key, so the program itself is working, just not the sound. I’ve checked all settings and connections, sound works fine otherwise. The only thing I can think of is, could it be my QWERTZ keyboard (Germany) as opposed to QWERTY (US etc.), in connection with Catalina, might be the cause? Or does anyone have another idea?

can you post screenshot of the audio module?

1 Like

I believe Catalina has weird permissions things you need to set. Had to do it once for a friend, where you have to allow an application access to the microphone/line-in. Have a look in your system preferences.


Hi Omer, here’s the screenshot of the audio module. “Hauptger” should read “Hauptgerät”, but apparently the letter a-with-umlaut isn’t supported - it means “main device”, = I’m assuming the iMac itself, although that’s a bit puzzling, since the built-in output (1-2 out) should be the iMac’s speakers. Whatever “Hauptgerät” designates, no sound comes out when I check that instead of built-in output.

Yeah, its annoying. Doesn’t always pop up the right dialog, or its hidden behind all of the active windows. Sometimes you have to have the System Preferences->Security & Privacy window open while you use an application to see dialog option that you need to allow.

1 Like

That was the first thing I checked, and have tried all possible combinations (output in the iMac and options in the Rack audio module), but there’s just not that many total options.

Hi, sorry but I’m not sure what you mean with having the preferences->security window open the intended dialog option - do you think it’s worth explaining? The only thing under security that has anything to do with sound, that I can see, is under “data security” (“Datenschutz”) > microphone, but the box next to Rack is checked, allowing access to the mic.

A post was merged into an existing topic: Error on launch “Rack’s resource directory “n_…/res” does not exist” on Mac