Error on launch "Rack's resource directory "n_.../res" does not exist" on Mac

Thanks - this worked. Moved VCV app into Applications folder then into Dock.

I experienced the same issue on Mac OS 10.8 and the above mentioned tips did not help. But I managed the get it to work by right clicking on the app and selecting "Show Package Contents and open it by double clicking /Applications/

1 Like

I have this problem: Last login: Tue Mar 24 09:25:48 on console

/Applications/ ; exit;

mkdir: /Users/alviselupo/.bash_sessions: Permission denied

touch: /Users/alviselupo/.bash_sessions/A4DCB0DE-DD11-44D4-BE0C-4EFD83CEAA5F.historynew: No such file or directory

macbook-pro-di-alvise-lupo:~ alviselupo$ /Applications/ ; exit;

Could not open log at /Users/alviselupo/Documents/Rack/log.txt

Thank you! That did it!

Hello, I tried in both ways: opening from the package content, and thru the app folder. but doesnt work. The system tells me “its damaged. move to trash”. how can i fix it? im on mojave 10.14.6

Just bumping- This is happening for me in Mojave as well, except in my world I can open Rack in Terminal by clicking on /Applications/

Copying and pasting the Rack App to applications, or the dock does not allow me to open it.

Newbie here. I got the following screenshot and although I can use VCV Rack in Mac OS Catalina…I cannot view other files downloads?

Dear all,

I have trouble opening the VCV Rack 1.1.3 version on my Mac OSX 10.10.3. During the last week I have read the previous threads and posts about people having trouble opening the program. Following previous advice was to no avail. The task manager shows the program as running, but nothing is showing up.

I would appreciate your help.

Kind regards, Robert

Delete and reinstall V 1.1.6 :slightly_smiling_face:


It’s possible that some Modules have updated and require things that were not in Version 1.1.3. I also think dowloading version 1.1.6 should resolve the problem,

Let us know if it’s not the case :slight_smile:

1 Like


first off, thank you for your help. I appreciate it.

Here is what I did:

  • download VCV Rack 1.1.6 to downloads folder
  • unzip in download folder
  • drag RACK into applications
  • double click on RACK icon

Received this message: Rack’s resource directory “n_0_381021/res” does not exist. Make sure Rack is installed and launched.

  • Tried to start RACK from Dock. Nothing opens.

  • Deinstalled the program

  • dragged the zip folder to application folder

  • unzip & open rack Result: Rack’s resource directory “n_0_430185/res” does not exist. Make sure Rack is installed and launched.

Also look/read here : ?

Andrew :

1 Like

Same Here. Any fixes?

I accidentally deleted the program and can’t install it back. Received this message: Rack’s resource directory “n_0_528513/res” does not exist.


I was starting to get a similar one.

This is on MacBook Pro (2019) running Catalina 10.15.7 But - this only showed up after a patch was (apparently) successfully loaded, Some of it was running and putting out sound, but when I pushed a button to trigger Bidoo’s póUPrè sampler, it crashed.

That patch had been working previously (a week or two ago). Sadly, póUPrè does not indicate which wav file it had been trying to load, not even by right-clicking on the module. I’m pretty sure it’s this 11-minute wav file, and it has not been moved around.

New development: Rack crashes when I just try to open that patch. The frozen Rack window still shows the File menu still dropped down.

Where exactly is it looking for the allegedly missing resource directories? Should it be buried somewhere in the /Applications/ directory?

@morteneriksen1971 I followed your way and got this : Last login: Tue Apr 13 13:06:06 on ttys000

Philippes-MacBook-Pro:~ philippegiron$ /Applications/ ; exit;

objc[1816]: Class FIFinderSyncExtensionHost is implemented in both /System/Library/PrivateFrameworks/FinderKit.framework/Versions/A/FinderKit (0x7fff986de3f0) and /System/Library/PrivateFrameworks/FileProvider.framework/OverrideBundles/FinderSyncCollaborationFileProviderOverride.bundle/Contents/MacOS/FinderSyncCollaborationFileProviderOverride (0x10c51f50). One of the two will be used. Which one is undefined.


Saving session…

…copying shared history…

…saving history…truncating history files…


I’m a complete dummy when it comes to IT so I’ve no idea what to do. I can open VCV and it works seemingly fine, but I cannot load any patches downloaded from external sources.

Any clues? Thanks in advance.

BTW links such as the above are now 404ed because all Issues are hidden in VCV Rack repositories (I see “Code,” “Pull Requests,” “Actions” etc but no Issues).

So there is some knowledge about how to handle the resource directory problem, but it is currently unavailable.

I’ve got two students with this problem – would be quite helpful to read those.


Try running in a terminal

xattr -r -d /Applications/VCV\

(or wherever you installed Rack) and re-launch Rack. If that doesn’t work, you can always try launching the Rack binary from the terminal.


OK, thanks :clap: