Unable to obtain xcode 12.4 disk image to set up tool chain, found sdk randomly on the web.

Hi all, I’m trying to set up the toolchain, but I’m unable to find the appropriate Xcode.dmg file required by GitHub - tpoechtrager/osxcross: Mac OS X cross toolchain for Linux, FreeBSD, OpenBSD and Android (Termux) in order to create the sdk required for the mac version: the only available files appear to be xip format.

I’ve tried to decompress the xip file, and attempted to use the cli tool download instead, but so far, nothing has worked. However, as I was getting ready to post here, I did a search for the required sdk - MacOSX11.1.sdk.tar.xz, and found this repo: GitHub - phracker/MacOSX-SDKs: A collection of those pesky SDK folders: MacOSX10.1.5.sdk thru MacOSX11.3.sdk , which has archived a version.

I’m wondering:

  • what did I do wrong that prevented me from following the original instructions?
  • does using this random repo’s version of the sdk make sense?

Thanks all, I have a lovely, awesome, game-changing (IMHO) utility plugin to share with you at the end of this journey.

1 Like

FYI: the sdk from the repo above did not work. A kindly fellow member of this forum was able to help me out however.