Unable to install VCV Rack 2.0.0 on Windows 10

Nick thank you for replying! I did what i usually do to make the program install by granting permission but nothing happens after that point! vcv|455x342

Tried a few things but still no luck.Neither the free rack or the rack pro 2.0 install on my system! I had vcv 1 running fine!

1 Like

Hmmm … sorry, not sure of the cause then.

There was another thread that suggested jack be the culprit, but I don’t even have it installed!

its been almost half a month and i havent had any luck from the PRO support to get this running yet! I hope Im not the only one facing this issue! If anyone else is please let me know how you got the installer working on windows 10!

It works for most people, but there’s plenty it doesn’t work for. I would be super usefully to have some thread or wiki page somewhere with the standard tips on it.

Still no luck installing VCV Rack 2.0.3 ?

https://vcvrack.com/rack#get

Changes were made since 2.0.0



Windows related solution threads (incomplete)

Specific VCV modules

Im facing the same issue … Rack2pro is installed but can’t run even in in standalone mode .rack 1.1.6 runs fine…i tried many things that the forum proposed but still no luck on windows 10… from the log file something has to do with the wasapi drivers i think ill post the log file later on so maybe u can help.

[0.001 info adapters/standalone.cpp:137 main] VCV Rack Pro v2.0.3b [0.001 info adapters/standalone.cpp:138 main] Windows 10.0 [0.001 info adapters/standalone.cpp:144 main] Args: C:\Program Files\VCV\Rack2Pro\Rack.exe [0.001 info adapters/standalone.cpp:147 main] System directory: C:\Program Files\VCV\Rack2Pro [0.001 info adapters/standalone.cpp:148 main] User directory: C:/Users/tapet/OneDrive/Έγγραφα/Rack2 [0.008 info adapters/standalone.cpp:152 main] System time: 2021-12-18 14:23:35 GTB Standard Time [0.008 info src/settings.cpp:455 load] Loading settings C:/Users/tapet/OneDrive/Έγγραφα/Rack2/settings.json [0.008 info adapters/standalone.cpp:175 main] Initializing environment [0.022 info src/rtaudio.cpp:240 RtAudioDriver] Creating RtAudio WASAPI driver [0.041 info src/rtaudio.cpp:255 RtAudioDriver] Found RtAudio WASAPI device 0: Speakers (High Definition Audio Device) (0 in, 2 out) [0.265 fatal adapters/standalone.cpp:60 fatalSignalHandler] Fatal signal 22 SIG. Stack trace: 16: 0x0 15: raise 0x7ffbcdc3ac60 14: abort 0x7ffbcdc3f270 13: ZN9__gnu_cxx27__verbose_terminate_handlerEv 0x7ffbaa51f4c0 12: ZN10__cxxabiv111__terminateEPFvvE 0x7ffbaa515cd0 11: ZSt9terminatev 0x7ffbaa6078d0 10: _cxa_throw 0x7ffbaa610670 9: ZN5RtApi5errorEN12RtAudioError4TypeE 0x7ffba4115a20 8: ZN11RtApiWasapi13getDeviceInfoEj 0x7ffba4121870 7: ZN4rack13RtAudioDriverC1EN7RtAudio3ApiE 0x7ffba4154580 6: ZN4rack11rtaudioInitEv 0x7ffba3cb0310 5: ZN4rack11rtaudioInitEv 0x7ffba3cb0310 4: ZN4rack11rtaudioInitEv 0x7ffba3cb0310 3: ZN4rack11rtaudioInitEv 0x7ffba3cb0310 2: ZN4rack11rtaudioInitEv 0x7ffba3cb0310 1: BaseThreadInitThunk 0x7ffbcc897c10 0: RtlUserThreadStart 0x7ffbcdf8ce80

rename user folder , delete asio4all, disable multiple devices still stops there…any thoughts?

I have the same issue but with free version. I uninstalled the old VCV version and installed VCV2, I gave it permissions and nothing is happening after I double click the icon to start the program.

its strange…on another win 10 machine run ok with the first install so i think something has to do with the configuration of the pc… i thought might be the asio soundcard so i deleted the drivers but still no lack…

1 Like

It’s ONE DRIVE that’s likely causing issues. All the files must be stored locally on the PC

Yes i put the user folder outside one drive and also disabled unnecessary audio devices in windows settings…i managed to run vcv vst in ableton.in standalone i get bsod , im sure this has to do with my asio soundcard drivers…

my problem is still not solved (i tried also 2.0.4 version). I recorded a video:

send it to VCV - Support

1 Like

Done! I will wait for an answer

Checking others things, some from your other thread, but not shown in the video: Did you check for a Rack2 user folder (with Documents) and delete it before re-installing? Did you try pressing Win-D a few times while Rack was running to see if it reset the window position? Did you check the setting.json (without Rack running), and manually change the windowPos values to something like 200.0,200.0 ? Did the log.txt within the Rack user folder give any clues?

I removed all VCVrack versions from my computer with C:\Users\xxx\Documents\Rack folder and reinstalled vcvrack2 free (2.0.4) and got the same result. I didn’t see any settings.json file. But log file log.txt from the C:\Users\xxx\Documents\Rack2 folder (which looks the same as in my thread) contained this line:

[0.002 info src/settings.cpp:455 load] Loading settings C:/Users/xxx/Documents/Rack2/settings.json

I tried to create this file, but it didn’t help:

{
  "token": "xxx",
  "windowSize": [
    0.0,
    0.0
  ],
  "windowPos": [
    200.0, // also tried values here like -200.0 , 2000.0
    200.0  // and here
  ],
  "zoom": 0.0,
  "invertZoom": false,
  "cableOpacity": 0.5,
  "cableTension": 0.638930023,
  "allowCursorLock": true,
  "realTime": false,
  "sampleRate": 44100.0,
  "threadCount": 2,
  "paramTooltip": false,
  "cpuMeter": false,
  "lockModules": false,
  "frameSwapInterval": 4,
  "autosavePeriod": 15.0,
  "patchPath": "C:\\Users\\xxx\\Desktop\\synth_Test.vcv",
  "cableColors": [
    "#c9b70e",
    "#0c8e15",
    "#c91847",
    "#0986ad"
  ]
}

Win + D also doesn’t work for me ( and log.txt is clear

Strange situations always happen to me)

When I run vcvrack I see spinner that indicates that something is loading (about 3-5 seconds). I think the problem is in the display of the program

I don’t see a full log.txt in that thread, only a partial one, so I can’t suggest anything else from that. Does your system meet the minimum requirements for Rack, listed on the web site? In particular for graphics?

System requirements is OK for me. The problem was in JackRouter ASIO! ) The problem was solved when I deleted record from the Windows registry! See details in thread please if interested, thanks!)

1 Like

Its been almost a month. Still no luck getting VCV to INSTALL on my Windows 10 machine.

Even with the new 2.0.4 installer I get the same result!

Anyone else still facing what I’m facing?

I know its a tough time to expect support on this from them and I’ve raised a support ticket on this and even with the pro support im still here typing this.

Try this:

  • Go into settings, find UAC (User Access Control) and temporarily set it to the lowest/most permissive level.
  • Download/locate the Rack installer .exe file.
  • Right-click the .exe installer file and select “Run as administrator”.

Does that improve things? Also, remove any 3rd party anti-virus programs you have, and just rely in the inbuilt Windows Defender. These things cause so much trouble and are pure trash.

1 Like