Syntax error in libjansson while compiling on Windows?

I am building RackV2 from scratch on a widnows machine, following VCV Manual - Building While doing a make dep, I get a syntax error in the jansson library, which appears quite strange:

here it is:

/bin/sh: -c: line 1: syntax error near unexpected token `('
/bin/sh: -c: line 1: `/bin/sh ../libtool  --tag=CC   --mode=link x86_64-w64-mingw32-gcc -Wall -Wextra -Wdeclaration-after-statement -Wshadow -Wno-format-truncation -g -O3 -march=nehalem -fPIC -no-undefined -export-symbols-regex '^json_' -version-info 15:1:11 -Wl,-Bsymbolic-functions  -o libjansson.la -rpath /c/users/antonio/dropbox/Il mio PC (ANTONIO-PC)/Desktop/dekstop/vcv/rack20/rack/dep/lib dump.lo error.lo hashtable.lo hashtable_seed.lo load.lo memory.lo pack_unpack.lo strbuffer.lo strconv.lo utf.lo value.lo  '
make[4]: *** [Makefile:437: libjansson.la] Error 2
make[4]: Leaving directory '/c/users/antonio/dropbox/Il mio PC (ANTONIO-PC)/Desktop/dekstop/vcv/rack20/rack/dep/jansson-2.12/src'
make[3]: *** [Makefile:453: all-recursive] Error 1
make[3]: Leaving directory '/c/users/antonio/dropbox/Il mio PC (ANTONIO-PC)/Desktop/dekstop/vcv/rack20/rack/dep/jansson-2.12'
make[2]: *** [Makefile:362: all] Error 2
make[2]: Leaving directory '/c/users/antonio/dropbox/Il mio PC (ANTONIO-PC)/Desktop/dekstop/vcv/rack20/rack/dep/jansson-2.12'
make[1]: *** [Makefile:111: lib/libjansson.a] Error 2
make[1]: Leaving directory '/c/users/antonio/dropbox/Il mio PC (ANTONIO-PC)/Desktop/dekstop/vcv/rack20/rack/dep'
make: *** [Makefile:101: dep] Error 2

Any idea about this ? I can’t get past this error…

“Make sure there are no spaces in your absolute path, since this breaks the Makefile-based build system.”

VCV Manual - Building.

1 Like

Thanks I have always worked without spaces, from my desktop, but since I synced it using dropbox, the path has been changed to “Il mio PC (ANTONIO-PC)automatically, but It worked on Rack V1…

I also had some key signature-related errors on MSYS2 and I needed to fix them I moved everything ro to C:/Rack20 and this seems to work now

Also, you really shouldn’t be using Dropbox for this. Highly recommend against it!

Thanks, I use it to have an “automated” backup of important files, I will not use it now on…

But it’s not Dropbox that is causing this error. There seems to be some issue with building in paths with unusual punctuation. As a longtime programmer, I can say that even though this should work, you are playing with fire to use paths like that.

1 Like

yeah, It was simply “Desktop” until some time ago. When I decided to sync my Desktop with Dropbox, path names changed automatically