Sync issues with Keystep and Beatstep Pros

Hello there!

I have recently begun exploring a hybrid set up with vcv rack, external synths/modules, and ES-8. I have both the Keystep Pro and Beatstep Pro and am trying to clock them using vcv rack or visa-versa but am getting some strange results.

Syncing VCV to Pros
I have read that vcv does not like being clocked from external sources and have experienced that myself.

When syncing via USB or MIDI, vcv may behave for a while, but will inevitably get out of sync when my computer tries to think about something else. I have also noticed that when looking at the USB or MIDI clock on the scope, vcv is obviously missing some gates.

When syncing via CV, it seems vcv rack receives multiple gates per beat.

For example, for every quarter note output by the Pros, I can see three pulses going into the ES-8.

Syncing Pros to VCV
When syncing the Pros to vcv via USB, MIDI, or CV, the bpm registered by both the Pros is wildly slow.

For example, if vcv rack is outputting 120 bpm, the Pros will see this as 30 bpm and run thorough each step of a sequence comically slow. This is especially obvious when syncing through USB or Midi. I can get the sync somewhat in check using a multiplied CV clock from vcv and playing around with the clock rates of the Pros, but this is janky at best.

Am I missing something here?

Thanks in advance for any advice or tips!

I sync VCV (slave) to Beatstep Pro (source) by using the clock out from the BSP in to my audio interface then in to VCV. It is reliable and stable. Then connect from your audio in module to the BPM in on Clocked set to 24ppqn. @Omri_Cohen has a good video on YouTube.


From your OP, it sounds like you need to get your head around PPQN values (pulses per quarter note).

Syncing VCV to Pros

VCV is absolutely fine when being synced to an external analog (audio pulse) clock.

Take your clock pulse from the audio module into Impromptu Clocked, make sure it is set to the correct ppqn, and you are good.

Send your external clock pulse into Clocked’s BPM input, then click the Mode button to set the correct PPQN value - ‘P4’ on Clocked = 4 PPQN for example.

Be aware that very short clock pulses are often missed by VCV scope because… they are just too short. Doesn’t mean they are not there, just that the scope can’t detect and display them quick enough

Syncing Pros to VCV

VCV can send a perfectly good clock out for external gear to sync to.

A 1x clock out of VCV is 1 PPQN, this means one pulse is sent every quarter note. If your external gear is expecting a 4x clock (4 PPQN) then it will run four times slower than expected with a 1 x clock.

I think the default with the Arturia Pro’s is “1 step Clock” (although this can be changed in Midi Control Centre application). This is equivalent to 4 PPQN. This explains why your hardware is running at 30 bpm rather than 120 bpm when sent a 1 x clock from VCV. Send it a 4 x clock and all will be well.

1 Like

You can set the clock behaviour of the Beatstep Pro in the Arturia MIDI Control Center. I have set it to 2PPQN (8th notes), which is the Korg standard and works best and most stable for me.

Usually I sync to the MIDI clock by taking a MIDI-CV module in VCV Rack and setting the clock to 8th notes, which only works stable as long as my buffer size is very small.

Syncing to the clock via an audio input is much more stable, but for me the audio signal always arrives a few ms. after the midi, so it’s stable but always a bit too late… was thinking about asking about this here, since I think it’s strange…

So all in all my best solution now is to use a MIDI clock with 8th notes, which gives me the least jitter, to sync the internal clock and sequencers - and another clock on an audio input to sync delay effects, so they are 100% stable.

1 Like