Stoermelder MIDI-CAT MIDI note behavior.inconsistent!

This is driving me nuts @stoermelder !

Sometimes when I add a MIDI-CAT to map the mute buttons on MindMeld Mixmaster. When I try and map a MIDI note to a mute button, it instead treats them as controllers. Meaning that when I right click on the mapping in MIDI-CAT UI, it shows this:

image

This means I can’t set a mapping of (for example) C#1 to Toggle mode, which is what MindMeld Mixmaster mute buttons expect. If I do map C#1 to a Mute button on MixMaster, nothing happens when I press C#1 on my controller.

When it MIDI-CAT works correctly I go through this rigamarole to get the mutes mapped on Mixmaster.

  1. Map one key, C#1 for example, to a mute button.
  2. Right click on that first mapping in the MIDI-CAT UI, and set the input mode to Toggle.
  3. After that you can map other keys, and it will follow the ‘Toggle’ mode of the first mapping.

Is there a way to set up MIDI-CAT so it works predictably to map MIDI notes?

The UI changes depending on MIDI notes and MIDI CC… if nothing is mapped to a slot some of the settings are hidden. Can you try mapping the MIDI controller first and then your buttons on the module?