Southpole Nov 2019 crashed my VCV Rack

Hello everyone, Earlier I downloaded the Southpole Nov 2019 version 1 makes and placed them in Rack/plugins ver 1 folder and now even though I have removed them from that folder, every time I search/ attempt to add another module VCV Rack crashes, any ideas on how I can get to the rack I had before trying to add the Southpole Ver 1 updates? I have restarted and shut down my pc [ Windows 10X64 ] but still get the same problem, do I have to update VCV Rack? Thanks Adrian/ Kleinemaschinen

You could try renaming or deleting the autosave file in your Rack directory.

@ady34 Did you by any chance update squinkylabs also ?

Try my fully up to date Win build here:

Thanks Troubledmind, I deleted the autosave file but still get the same issue, still crashes when I open up module browser. Any more ideas are very welcome.

I did or should I say the Library advised me to update Squinky Labs before adding the Southpole modules, could it be that update that threw a spanner in the works? Any more advice welcome. Thanks

Remove the folder and download this :

After that install southpole from Steve Russell a few posts back.

Huzzah, the Squinky update was the problem! Well at least the module browser doesn’t crash Rack. Are the Southpole from Steve Russell stable versions? I will have another go at putting them in the plugin folder. Hopefully no more problems will ensue. :wink:


Yes (but netboy3 version is too) :+1:t2: :smiley:

Busted! Yes I am the culprit.

Oh you naughty boy, stand in that corner over there and don’t come back until u realise what you have done! :rofl: :skull:


Library is asking me to update Squinky labs again, is this the new safe version? Don’t want to have the same problems!

AFAIK it’s a DOWN grade from 14 to 12 , so yes it’s safe. (but you’ll lose the compressor)

correct. and when it [finally] goes to 15 it will be safe too.

1 Like