Some weird behavior of the perfomance meters

here on a ubuntu after a fresh compiled rack version 2.1.1:

-0.3% CPU would be great :wink:

I have this issue permanently so to make sure i compiled the newest version from scratch…

What i have found out so far: After a restart of the computer its OK. Then after a while this behavior comes. I don’t know possible causing actions but may be:

Set the performance cpu mode to from ‘demand’ to ‘performance’

– this was my first guess,

but as i have developed modules recently i did not make this setting.

But still after a while the issue comes suddenly.

Next guess: Set Threads to 2 and the back to 1 – not really sure about that.

However,has someone similar issues?

What could be the reason? Thanks.

You don’t seem to have an audio device selected. I was under the impression that the engine doesn’t run at a reliable speed without an audio device.

does not matter. get the same if selected.

Does the rack engine sample rate match the sample rate on your audio device?

yes “auto” is selected and it takes the settings of the JACK 2 config 48000HZ, Block size 256. And it works perfect after a reboot for some time.

next time it happens, I’ll restart jack, maybe this helps …

It would :slight_smile:

Looks normal here on my macOS/Rack Pro 2.1.1:

Works well on windows 11 for me. One “trick” I use is that if the numbers are all super small I might not believe them so I up the sample rate. If you go to 4X rate the CPU usage should go up by more or less that amount.

1 Like