scripts in VCV (prototype missing in v2 ?)

I’m keen to create a quick and dirty VCV rack module to try out my ideas… Id love to be able to use a scripting language such as javascript or python. I cant get the prototype module working in V2.

Anyone know if its possible to write a rack module in python?

Maybe try using the Prototype module in V1. For sketching out ideas I think there’s no big difference between Rack V1 and V2.

yes, I also have some scripts in Prototype that would be good to bring into 2. I have never been able to get the actual build system working on my machine to compile stuff,. but scripts are great for sequencing and modulations.

hello, this maybe help a little.

git clone --branch python

I haven’t tried it, I look at Vult-Playground.


“Python” is a stale branch. “V2” is the only active branch

Seems like you need the fix from here to run it in v2:

Would be interesting to hear if anyone can actually build and run it in v2…

I was able to build it in Windows, use sleexyz’s repository.

Two complications:

  • MSYS 64bit uses premake5, so, one has to download premake4 from here Index of /mingw/mingw64/ and install it with pacman -U mingw-w64-x86_64-premake-4.3-2-any.pkg.tar.xz
  • I was only building the LUA backend, so, in the makefile disable all other platforms (or figure out how to build those, I just didn’t try)
  • I had to change line 507 of src/Prototype.cpp to std::wstring commandW = rack::string::UTF8toUTF16(command);

Then it worked with the Lua backend :slight_smile: [But I could imagine that the other languages still require extra work.]


I got it to work on windows too but I only did the JS backend. I don’t remember all the issues I ran into but the ones steffen mentioned sound familiar.

There are also some pull requests out on the official repository that I think address issues

1 Like