Saving settings with Nysthi JannekerTimed and Holonic Systems Gaps

Well this is odd - I’m used to all the modules I use saving their current settings when I save a path.

But I just created a small patch that uses Nysthi JannekerTimed and Holonic Systems Gaps, and both are giving me issues. I’m using the most recent library updates in VCV V2.

For Gaps I want to use the As Is mode, but every time I load the patch it comes up as Gate2 mode. I don’t have this problem when using VCV V1, so I’m assuming this is a migration bug.

For JannekerTimed I want to be able to save the Seconds value, but it always initializes to 1 when I load the patch. I don’t know it this is by design, or a bug, or some hidden feature that I can’t discover without documentation.

Anyone else having similar issues? or solutions?

@DaveVenom just tested J-timed : seems correct to me

remember that is just a sequencer of timers

the only thing I don’t save seems to be the time scale (first field) (going to check it) (I’m sure was working: maybe some “lost in translation v1 - v2” )

in 2 0 15 the time scale is saved correctly (now)

OK, I finally figured it out. I didn’t realize I need to press the Update button to save the value for when the patch is reloaded, (or to preserve the setting if moving to another scene and then returning). Now the Reset does what I expect as well.

Now that I understand how it works, the very brief explanation in the Changelog “documentation” makes sense.

  • UPDATE TAP/TRIG will update current store scene from the screen

But it was a bit of the chicken or the egg. That statement didn’t make much sense to me until I better understood how the module works, and without full documentation, I was struggling to make sense of the module.

And now that I understand, I have a much better appreciation for what J-Timed does. It is by far the simplest module to use to meet my needs.