RtAudio ALSA vs raw JACK performance/stuttering observations


(Skrylar) #1

Some observations:

  • On a test desktop it’s possible to get quite a good few heavier modules going and everything works out. Although there are occasional underruns mentioned in the logs. This is probably to be expected, so moving on…
  • On a notebook, a lot less modules are needed before Rack starts going on a crazy stuttering spree.

Here’s the control patch I was playing around with when the audio started losing it’s mind. It’s not a particularly demanding one:

I tried the FPS limiter from Jim’s fork and it didn’t do much (thought the cpu was competing with the audio, given the use of integrated video here.) Turning up multi-threading actually made the stuttering worse which was also unexpected. Searching brought up this old thread about sudden stuttering troubles after the RtAudio switch so I tried swapping in a JACK module and using that.

Now if the computer just isn’t powerful enough to run this patch, there should still be stuttering. Except there isn’t any even at identical block sizes.

I haven’t controlled to see if killing Pulse makes the problem go away on the pure-ALSA side. I know there are historical issues with sharing ALSA and Pulse, but these issues don’t exist on the other machine under the same conditions. One is AMD and one is Intel, but their clock speeds are comparable. It’s weird and baffling :thinking: