Reaper and VCV Rack: Sync issues


(Domharrison) #1

I thought i’d be the one to start this topic off since I am soo close to having these two amazing tools fully synchronised. How are you using REAPER with Rack?

I do all my sequencing in Rack and I mix in Reaper pretty much as I go. I used to just dial in the same tempo and record multi-track using VCV Bridge, but recently I have found that using MIDI CC with Bridge with a tempo-synced square LFO parameter modulation in REAPER results in the best clock sync, having tried midi clocks like MIDI-1 and the third-party ones, which don’t work at all well for me.

Now we get to the alterior, selfish motive behind this post :open_mouth:: My one remaining issue is that for some reason I can’t get Run or Reset messages to work properly. The reset/run message, just a few automation points at the beginning of the track sent via MIDI CC Bridge, seems to work better on a separate port to my audio and my clock, but there is still nearly always a glitchy moment of lag and great anticipation to see just how far off the beat it will end up at the 3rd bar. When i do manage to sync them up
the satisfaction and flow is immense! Does anyone know a work around for this? Maybe a nudge plug-in or something?

I hope I’ve helped spark some ideas and that we can share ideas to use these two amazing programs together to their best potential!


(Skrylar) #2

Do you have some minimal example patches of the clocks and triggers desyncing?

Some very minor drift is probably inevitable, although if clock pulses are coming in via MIDI it shouldn’t be getting significantly far apart :confused:


(Domharrison) #3

I’m just sending a trigger at the start of the track via MIDI CC on an automation lane using Bridge. The clocks are in sync until VCV is reset by the trigger.

I’ll try putting the trigger somewhere else on the timeline when i get back.


(Domharrison) #4

Good thing i woke up with the thought to put the reset at bar 2… the sync is now perfect haha :slight_smile: funny how that happens sometimes…

Here I have a track, “BRIDGECLOCK”, that is sending data to CC0 and CC1 in Core - MIDI CC in Rack. CC0, “CLOCK” is a tempo synced. square- wave LFO parameter modulation, which, for me, provides the simplest, best sync out of all the methods that i have tried.

CC1, “Reset”, is what was causing the issues. For some reason, placing the automation item 1 bar later has solved the issue of the clock stuttering and going out of sync after sending the trigger to the reset of my sequencer.

I hope this helps others who are having sync issues.


(Skrylar) #5

Cables in Rack do carry with them some 1-sample delays, and modules are encouraged not to reset and continue playing within some samples of a reset. Might be relevant?


(David Muddyman) #6

Forgive me I am probably as thick as a whale omelette but I have looked at the above and don’t really understand.

I have been able to get eight separate outputs from VCV Rack into Reaper with no problem using ReRoute but now I want to sync the two together so that the clock in VCV runs when I press play or record in Reaper. I tend to use CLOCKED as my clock source in VCV but using bridge I cannot seem to get the run to enable using the clock 1 output of MIDI 1 core module or the reset to action using the start output of MIDI 1. This is how Omri used it in his video.

Can anybody help with this?

Thank you

I have added the patch that I am trying to sync ##softskin - reroute.vcv (91.8 KB)


(David Muddyman) #7

I think I have sussed that it doesn’t work with Clocked or the MSCHack lock but does work as an input clock for sequencers. So please forget about the above unless you have any other ideas about syncing with Clocked or another clock


(Rémi Collin) #8

What I do in ableton, but I guess you can do this in reaper too is : I use an audio pulse that I route into VCV audio input via internal audio routing, then into Impromptu Clocked BPM IN, using PPQ24 as resolution. Audio is sample accurate, opposed to midi which has jitter. Then it’s all a matter to offset the pulse track to compensate for latency and be perfectly in sync.


(Stephan) #9

have you set Clocked to the right mode?
under the BPM input is the mode button
you need to set it compatible to reaper (not in CV mode)


(Domharrison) #10

I couldn’t get it to work with Clocked so i just made my own version with the clock coming from the Modulation Envelope Clock Track in REAPER patched out to the SynthKit Clock Divider patched to a few BPM LFOs. I think there’s a new mode for BPM detection in Clocked like rsmus7 said, but I haven’t tried it; if it does work let me know. :slight_smile:


(Domharrison) #11

I think i tried that before, might have to give it a go again because it’s probably a more sane way to do it. I’ve come to like that i can’t stop the clock, but it is a bit inconveniant.