re downloading vcv rack pro without having to repay for it

Can someone please advise me how to redownload VCV rack 2 without having to re buy it. My old computer has gone to meet its digital maker. I transferred the original files to the new one and can load that version, BUT when I try to upgrade to latest version, I get a message that ‘programme not paid for’.

Any help gratefully received.

sounds like something to email their support about at


If you transferred all the files, rather than downloading and installing anew, it’s probably that your installed license keys are no good on a different machine.

I’m guessing that per-machine info is encoded into the license files to help prevent theft. If it were otherwise, you could just copy the keys around and thereby steal from VCV and paid module owners.

Assuming this theory is correct, you can recover by moving the licenses\*.vcvkey files elsewhere (in case what I suggest doesn’t work, and you need to restore them), then running Rack and logging in with your original credentials. Rack will then install new license keys for the new machine, and you should be good from there.

1 Like

You can try going to

“log in” is on the top right. Use the email you used when buying Rack Pro.

Scroll down, and you should see the download buttons. (If not registered for that email, there will be “Buy” buttons.)

If the problem is connectivity from the machine you want to run Rack on, you can generate a license on The account page - using the machine ID shown if you run VCV Rack Pro without being connected to the internet.


Thank you for your reply. Having had no success with your suggestion, I delved through a couple of years ofemails and found the receipt dated Dec 2020. Sent this off to support to try and get this resolved. I had originally contacted them but had no reply hence contacting the community.


I think that it’s all a matter of logging in with your account on the website. It will recognize that you own the pro version, and will let you download it. I have done that multiple times. It should work :slightly_smiling_face:


Thank you Omri and to all others who took time to respond, problem solved. As with many things this came down to user error. When I first registered my purchase about 3 something years ago, I made a typo in my email address and so that error was saved. When I tried to update the system could not find it as it was an incorrect address, so again my grateful thanks to you all.

1 Like