RareBreeds Eugene not working - solved

изображение I downloaded this plugin, I’m trying to add it. But when I write this plugin in the search engine, it just comes up as a black square. When I add it to the track itself, it still doesn’t work. изображение

Are there any error messages in log.txt ? (it’s in your user folder.)

With this plugin, only that is written. The rest is autosave.

Looks like the panel SVG can’t be found. What platform are you on?

Windows 10

When you right-click on the (shape of) the module like this:

and click on Open plugin folder, you should see this :


Inside the res folder is this :

Yes ?

1 Like


Is it the only plugin not showing the faceplate in the module browser ?

No, the OP showed pics of the missing panel in both the browser and on the rack.


My guess is your username has some weird letter in it and this plugin does not like that :

But maybe Paul has a better solution ( he is still typing).

1 Like

I have seen a similar problem with other plugins. There is a bug somewhere that causes some files to not get unpacked from the newly downloaded plugin package. For some modules this results in a missing panel image as in this post but can also manifest as a crash.

The workaround solution to this ‘incomplete install’ issue is to delete the entire plugin folder, restart Rack, and update modules again.

Examining the files as indicated by @Yeager will tell you if it’s this missing file issue. If not, then it’s time to report the bug to the plugin developer.

1 Like

I did everything as written, but rack automatically creates a new folder in the user’s folder

So you have made a copy of the rack2 folder on your C drive like C:\Rack2 and you added this to the variables

And when you start Rack2 it does not look in C:\Rack2 but in the “old” folder in documents ?

If so could you try this :

“C:\Program Files\VCV\Rack2Free\Rack.exe” -u “C:\Rack2”

1 Like

Before doing all that, it would be good to verify that it is indeed the case that the path to the plugins folder contains non-ASCII characters. I haven’t seen anything in the thread yet that shows the full path to the plugin folder.

Moving the rack “user folder” (-u) to a path that contains only ASCII is a workaround. If this is the issue, the bug should be reported to the plugin developer (and then do the workaround ;-).

1 Like

the path does contain characters that shouldn’t be there, but I can’t change that unfortunately.

I’m sorry, I don’t quite understand. The program itself is located in D:\Rack2. How does this relate to plugins?

Rack doesn’t install plugins in the same folder as the program. It uses the Rack “user folder”.

The Rack user folder is one of:

  • folder specified with the -u command-line parameter (which @Yeager showed how to do using a shortcut for launching Rack).
  • the USER_DIR environment variable (Which @Yeager shows using the Windows settings)
  • or, if neither of those is in effect, the default rack user folder, which on the last couple of major Windows versions is C:\Users\<user name>\Documents\Rack2 (where <user_name> is your user name).

(Plugins go in <rack user folder>\plugins)

To workaround the issue with “problem” characters in the plugins path you can do what @Yeager has described. This will move your rack “user folder” to somewhere else (which will need to have a path containing only ASCII characters).

After you do that, then next time rack launches, it will reinstall all your subscribed plugins to whatever new user folder is in effect, if you haven’t moved the plugins folder there.


I figured it out, I did everything as said @Yeager . Looks like I did something wrong the first time. Now everything works. Thanks a lot!

1 Like

And now you see this ?


:smiley: :+1: