Rack freezes Arch Linux

Hello everyone.
I am not sure where to post this, I’m pretty sure this is not reproducible, so I’ll better post it here.

Rack freezes my Arch all the time, it can happen when I open a patch, when I open Rack itself, when I update my plugins. Sometimes I can just kill the proccess, but most of the time XFCE freezes completely, as well as keyboard and mouse stop working after a few attempts to open a terminal or switch to another TTY. Sometimes I can use Rack sometimes, but opening another patch can easily hang everything.

I’m still kind of a noobie in linux, so I’m not sure where to look and what to test. Right now I’m using realtime kernel, but I had this problem on vanilla as well. Tested different “audio” and “realtime” groups priorities and setting various memlocks in limits.conf, as well as unlocking it. Regarding audio I’m using Cadence, tried it with different bridges and settings, also tried starting jack via QjackCTL. “Realtime” option or number of cores in Rack doesn’t seem to affect this problem.

This is happening only with Rack, everything else is working fine, Reaper for example (native), FL Studio in Wine, any native game, any other app. Can anybody suggest what should I look for? I’m completely out of ideas now.

My specs:
CPU: AMD FX-8350;
GPU: NVIDIA GeForce GTX 1060 3GB (nvidia-beta-dkms 435.21-1)
Arch Linux with 5.2.14-rt7-1-rt kernel;
Xfce with Xfwm4;

Thanks in advance.

The place to look for is on github here:

Search for your problem first. Andrew does not typically respond to problems here, though there are many expert users lurking hereabouts.

1 Like

The realtime option in Rack can cause this in my experience. I know you say it doesn’t make a difference but it’s one less variable to think about.

Is anything written to Rack’s log when the crashes happen?

Log doesn’t have any errors in it, unfortunately.
System still hangs with “realtime” turned off eventually, with less performance on top of that.
First thing that comes to mind - pulseaudio. I need it for certain applications, also ALSA -> Pulse -> Jack method is working just fine for everything else. Of course, pulse might not be the cause of problems at all, just my speculation.

I don’t think pulseaudio or the bridges will be making much difference, particularly if it’s only Rack that causes the problem. Have you tried the regular kernel instead of the RT? I’ve heard of Nvidia + RT kernel causing lockups. The stock arch kernel is built as a ‘lowlatency’ kernel (as far as I remember) so it should work perfectly well.

Yeah, I mentioned “vanilla” kernel in my initial post.
Not so “lowlatency” for me, btw. I had to switch to rt-kernel for guitar recording. But for Rack it’s a very small latency difference, ofc.
Though, that gives me an idea to test different video drivers just to see if it makes any difference, because I had nvidia on both kernels.

Ah ok, sorry missed that.

A few small details:

  • Lockups usually happening when I load a saved patch (as I already mentioned)
  • If it did happen, I will need to delete autosave from .Rack folder
  • Upon launching, Rack will message me about recent crash and ask if I want to start a new patch - choosing “Yes” will end up in another lockup, but “No” will load template file just fine