Rack forgets MIDI port(s)

In my template patch I have some connections to outboard midi devices pre-patched with CV-MIDI. It has always been annoying that, for some reason, I have to re-select the midi ports very regularly. I was hoping this problem would go away with V2, but it did not. It’s probably not a Rack problem, but Windows related. But in any case, if anyone knows what can be done about this, that would be much appreciated.

I am on Windows 10. I have a few midi interfaces, the main one is a Motu Midi Express, and I use the Midi interface on my sound card as well. And a Behringer BCR2000 and a BCF2000 It seems Windows changes the order in which these interfaces are presented sometimes, and sometimes the names change too, as if there has been a new driver added for the same interface. So you will see BCR2000(1), later that will be BCR200(2).


this is a common problem on windows, which is related to the device ID Window is assigning to midi-devices. The only workaround besides payed midi-organizer-software is to turn on your midi-devices always in the same order.

1 Like

After a bit of googling, this may be a solution as well:

Thank you. That’s interesting. Although I never change the USB-port, so that may not be the reason. My suspicion is that sometimes the devices are not initialized in the same order. But I will give this program a try!

That’s entirely possible especially on a laptop.

Well it’s a desktop, with everything always connected in the same way. And all the periferals are powered up before the computer starts. Let’s see what changes Markus’ little program has brought.