Rack doesn't look right on Arch linux

Looking for some help getting Rack to run on Arch. When I run Rack, none of the toolbar icons appear and the buttons/inputs also don’t look right:

Are there some dependencies that I’m missing? System info:

Operating System: Manjaro Linux 
KDE Plasma Version: 5.14.4
Qt Version: 5.11.2
KDE Frameworks Version: 5.52.0
Kernel Version: 4.19.12-2-MANJARO
OS Type: 64-bit
Processors: 4 × Intel® Core™ i7-6600U CPU @ 2.60GHz
Memory: 19.3 GiB of RAM

Are you running Rack using the instructions at https://vcvrack.com/manual/Installing.html#running-on-linux?

1 Like

Somehow it magically now has the correct appearance. I haven’t changed a thing!

I hadn’t seen that manual page yet, but I was/am running it with ./Rack. Thanks for directing me to the manual!

UPDATE: I reported incorrectly! I had put the unzipped Rack folder on my path and was just running Rack instead of ./Rack in the directory. ./Rack as stated in the manual did the trick.

I believe this is caused by a permissions issue. I ran into the same thing on my Ubuntu install when trying to launch Rack via a custom .desktop file I created, but ended up fixing it by using the absolute path in the Exec and Path lines. Here’s the resulting code:

[Desktop Entry]
Name=VCV Rack
GenericName=VCV Rack
Comment=Open-source virtual modular synthesizer

Until I added the absolute path, the program would launch with all the text and icons missing, and modules would often have some knobs or decorations missing. I’m no expert on *nix permissions, but this leads me to believe that when launched in some other way, the application is executed in such a way that the process can’t traverse directories correctly, and has problems accessing files it needs.

1 Like

yes, it is happen to me when I try to rum from a menu launcher, you must run it from the real location, a quick launch work to me very good


Hi there.
I had the same problem with vcv rack and Arch. Now it looks ok when started from directory, as you said, but the problem persists when I open saved patch from within the rack (menu ‘open patch’). After restart it looks normal again, but opening new patch always distorts the appearance. How to fix it?

Rack just asks to load its icons with a relative path; the OS resolves relative paths by looking at a process’ “working directory.” When you are at a shell, in the Rack folder, and run ./Rack, the working directory is the same as where the executable is and everything works. When you say go to your home directory and run Rack with an absolute path like /home/<snip>/Rack, the working directory will be your home directory. Providing the absolute path to the shell (ex. what setting Exec does) just makes it so the shell knows where to find the program, but the program still thinks it “lives” somewhere else and so when it asks for the files they can’t be found. Setting Path changes that “working directory” so even though you started it somewhere else (on your desktop) it still believes it lives in /home<snip>/Rack. This is why putting the absolute paths in both fields “fixed” your shortcut.

Correct. The “global” directory of Rack on Linux defaults to the current directory. You can set the global directory manually with a flag documented at the link I posted above.

Note that in Rack 1.0, the terminology changes to “system” directory, and the flag is -s.

Yep. I wayyyyyy overthought that one. Obviously the application is trying to load assets from a relative path, and it’s not magic. Like…I really don’t know what happened, but apparently for the past few months I just totally forgot the concept of the “working directory.”

This is why I will never be good at coding.