"Rack can't be opened because Apple can't check it for malicious software"

This is the message I’m getting after updating VCV. Anybody know how to fix this?

Right click and choose Open.

1 Like

I get the same issue - right click and open just brings up the same message.

Help!

Are you right clicking on the Rack icon in the applications folder ?

Yes

Just tried with VCV in a different location but get the same message :frowning:

Try CMD clicking on it.

No joy.

Hmm … some people in the FB group have mentioned tweaks in the System Security settings or even disabling SIP but you would have to look there. The usual right click and choose ‘open’ appears to have worked for most Mojave users (did for me).

Sorry that I can’t help further.

Hi - thanks anyway, i’ll see what’s going on in the security settings.

Hi.

This might be dependent on which version of macOS you’re using. You can check by going to Apple logo at top left > About this Mac to find out the OS version.

The Apple Support note “Open an app by overriding security settings” describes the process to follow:

You might also want to read the note “Protect your Mac from malware” as well:

You shouldn’t need to disable SIP.

The VCV Rack Twitter has also given help on this as well: https://twitter.com/vcvrack/status/1142123704215904257

Happy to help. I can do a screen capture and share with you if you like.

And welcome! :slight_smile:


Bottom line: Apple’s Gatekeeper is tripping you up. Run:

sudo spctl --master-disable

in the terminal and right-click open it again.

1 Like

See https://twitter.com/vcvrack/status/1142123704215904257

I assume that you are double clicking on the FileZilla install icon, yes? Don’t do that. Instead right mouse click on it. You should get the following: Select Open in context menu. Then the next dialog box you see will be similar to the one you report, but it will also have the Open button added. Choose Open and voila. Or you can give a check on this tutorial.