Rack 2 VST plugin crashes Reaper HARD! (SOLVED)

Hi just bought the pro version. Was just patching a bit using the VST plugin. The patch is fairly basic. Just 2 modules: Spectra and Audio 16. Mono in from audio 16 to spectra and 16 outs from the individual band outs of Spectra. Reaper channel is set to 16 audio channels. Saving the Project and trying to reopen crashes Reaper hard. Opening with the plugin offline works but then the previous work is gone… Anyone else having this problem? I also tried the same patch keeping the patch stereo>> result’s the same. Reaper version is the latest version (6.42) on a 2020 8 core i9 Mac running 10.15.7 Catalina

I just tested on linux and it crashes for me too. This seems like the bug to do with the way fonts are used (if you try to copy and paste the plugin it also crashes). It would be best to report it to support@vcvrack.com.

Cool, thanks I was already wondering where to direct the bug report!

Soundstage, Parametra, and Chords do the same. I’ll report those.

1 Like

Exchanging the Audio 16 for 2 instances of the Audio 8 creates the same problem.

Lots of plugins crash reaper tbh

Never had any problems before. Using Reaper for 7 years now.

It is an issue particular to third party VCV modules running inside VCV VST inside a DAW, so of course you never ran into this before. It never existed before.

If you can direct the bugs to the plugins that are causing it, that would be best. But that’s not always easy, and hopefully all the devs have seen these crash reports (there are a lot of reports like this one).

1 Like

If you had read well you see that the modules I’m mentioning are strictly VCV made modules.

Yes, It was clear from your message (which I read) that it is VCV modules. Why do you mention that? Or did you reply to me by mistake?

Since you’re mentioning third party developers maybe??!

oh! right you are. I am wrong.

And to be clear: Vertibration made a blanket comment that plugins in general crash Reaper (I won’t comment on that further). That’s why I mentioned that I never ran into that before. Of course you’re totally right this is a new situation with VCV inside a VST inside a DAW. :smiley:

yeah, I took that comment to mean “many VCV plugins will crash inside the new VST”. Admittedly I just jumped to that conclusion because of all the reports of that. But I was making a lot of assumptions :wink:

1 Like

Both Spectra and Soundstage have been updated now. Which solved the problem for me!

1 Like

I’ve got a perhaps related issue where I can use the plugin fine from Reaper, but after I save the reaper project it crashes every time I try to reload it in Reaper. This was a very minimal VCV patch I was using, basically so I could play it like a MIDI instrument, just Hora Detour, two Bogaudio 8FO, Alright Chronoblob 2, Valley Plateau, Mindmeld Mixmaster Jr plus AuxSpander Jr and an Audio 16. It’s a real shame as I’d captured quite a nice performance into an audio track, but I can’t seem to get it back.

The patch was same as this…

moving phases.vcv (4.3 KB)

…only difference was the Audio 16 and MIDI-CV were pointing to the DAW.