Rack 2 runs but no longer shows on display

I love this program but it’s buggy. I plugged in my large external monitor to my laptop while running Rack 2 (obviously a mistake). The program of course crashed. When I rebooted, I could hear the patch playing, and icon showed on Taskbar but there was no user interface on any display. I disconnected external monitor, nothing. I uninstalled Rack 2, reinstalled, and it seemed to take up where the last install left off. Nothing on display but the last played files could be seen when I right clicked icon on taskbar. Apparently uninstalling keeps all the old info. Anyone have any ideas?

Which OS?

this happens to me occasionally on windows 10

in the settings.json file in documents\rack2pro folder i can see that it has both a windowsize and windowpos parameter that is being tracked and when this happens its remembering the windowpos and windowsize like this…

“windowSize”: [ 0.0, 0.0 ], “windowPos”: [ -32000.0, -32000.0 ],

often to restore the window i press windows-d twice which restores the windowsize to 480x320 and is now visible… it seems you can trigger this behaviour by resizing the window while it is still drawing all the modules while its reloading the autosave patch

2 Likes

This happened to me also (Win 10) and was solved by pressing Windows+D several times in quick succession.

3 Likes

I close VCV by right clicking on the taskbar button , go to settings.json and :

I change the “windowMaximized”: false, to “windowMaximized”: true. and restart VCV.

"windowMaximized": true,
  "windowSize": [
    0.0,
    0.0
  ],
  "windowPos": [
    -32000.0,
    -32000.0
  ],

But this is a BUG :frowning_face:

1 Like

Yes, Windows D was the secret handshake did the trick. Forgot to mention I do have Windows 10. Thanks to all that replied.

I had a crash recently and VCV window didn’t show up at all ( it showed showed up in taskmanager and used the audio driver ) Win+d solved the issue thanks

Another option that should work is shift + right click on the VCV Rack taskbar icon and choose Maximize.

1 Like

Had the exact same problem, this fixed it perfectly. Thanks!

Hi, A somehow similar problem for me, maybe ? A patch I did run (audio is fine) but only shows one module, the rest of the grid is empty. This is the patch : Stages FM & LFOs mélancolique.vc.vcv (5.0 KB)