Rack 1.1.6 in Windows won't open patches made in macOS


I have received two patches from 2 different people running Rack under macOS and it appears that neither can be opened by Rack 1.1.6 / Windows 10 with all plug-ins up to date.

What’s troubling is the fact that there’s not even an error message. Also, the previous patch remains on screen.

What’s wrong?

Is there anything that looks like a warning or error in the log file? (log.txt in your documents\Rack folder)

Ah yes, the log file! I forgot about that one.

Here’s what I got (please note that I quit the app afterwards so some lines might reflect this at the end).

[515.034 info src/patch.cpp:163] Loading patch D:\ARTS² COURS\TRAVAUX\2019-2020\techSynth PE1 2019-2020\Raphael-Vincent.vcv
[521.846 info src/main.cpp:203] Stopped window
[521.846 info src/main.cpp:205] Stopping engine
[521.850 info src/patch.cpp:86] Saving patch C:\Users\xxx~1\DOCUME~1/Rack/autosave-v1.vcv
[521.852 info src/main.cpp:212] Destroying app
[521.852 info src/audio.cpp:302] Stopping RtAudio stream 2
[521.859 info src/audio.cpp:311] Closing RtAudio stream 2
[521.903 info src/settings.cpp:189] Saving settings C:\Users\xxx~1\DOCUME~1/Rack/settings-v1.json
[521.904 info src/main.cpp:217] Destroying environment
[521.968 warn src/bridge.cpp:362] Bridge server close() failed
[521.968 info src/main.cpp:225] Destroying logger

The issue seems solved when the files are transmitted by e-mail as .zip files instead of uncompressed files.

1 Like

Sounds most likely then it’s your mail client (or that of the sender) which is messing the files up.

I can’t see anything useful in that log file. It looks like you tried to load the patch, nothing further was logged, and then you closed the application 6 seconds later.

1 Like

remove the 2 from the folder name

1 Like