Problems due to failing computer, VCV Rack itself, or audio interface?

Hi All,

I can’t seem to find this exact issue in past threads. I really like this program, and am very keen to get it working properly, so any help would be much appreciated!

I’ll try to keep things in summary form:

  1. Sometimes, audio will cut out completely while a patch is operational. Other times, there will be no audio at all from startup, even when the appropriate outputs, inputs etc. are selected (I (think!) I know how to get sound out of the program, as I’ve made quite a few decent patches before, so I’m almost 100% sure it’s not a matter of not having chosen the right settings). Changing and resetting sample rates/buffer sizes results in clicking, but usually doesn’t fix the problem. Changing settings to match on the actual audio interface (a Scarlett Solo V3) also doesn’t fix it.

  2. VCOs have started ‘sticking’ on - but only additional VCOs after the first one, not the first VCO in a patch. I will attach some pictures here if I can, showing the default patch, with a single extra VCO added, to show what I mean. The CV is lit up bright on the output from the VCO, even with no input. It doesn’t seem to matter which VCO I add - connecting its output to the mixer, or any module in the output chain, will almost invariably result in that second VCO outputting at full volume, at a random pitch. It often also causes the ‘first’ VCO to start outputting non-stop as well. I can sometimes control the pitch with the input device, other times not. It doesn’t matter whether the second VCO has any input voltage going into it, it just starts firing on all cylinders. I have managed to rein it in by adding CV from an envelope to the mixer CV input, but as far as I know, this isn’t necessary for the default patch, and obviously this isn’t what you’d always want.

  3. This ‘rogue VCO’ issue happens with all VCOs from pretty much every manufacturer I’ve tried.

  4. My computer’s main OS SSD is failing (bad SMART status), so that’s one potential point of origin. I’m also running Windows 7.

  5. Here’s the interesting thing: I tried running VCV in Pop! OS (Linux) on the same computer, and both the audio cutout and VCO issue still happen. This is not running off the failing SSD - I was running it in trial mode off a USB stick. I’m also pretty sure I’ve had the same issues crop up on a completely separate laptop, running Win 10. The laptop is reasonably powerful (mid/high-end i7 from 2-3 years ago, 16GB RAM etc.). This last part is very puzzling.

  6. Going back to just the VCV modules (uninstalling the third-party ones) doesn’t seem to help.

  7. I also get occasional audio failure in Reaper (i.e. sound cuts out completely, transport bar continues moving but at weird, slow rate, etc. - requires restart).

Anyone have any input? Is it possible it’s another piece of hardware failing at the same time as my SSD? Faulty motherboard or RAM or audio interface? I don’t understand what’s going on, as the laptop shouldn’t have duplicated the issue in that case (even if it’s OK most of the time).

Current computer is an i5 4690k with 16GB RAM.

Pictures of the basic patch to be attached, if I can.


In this one, I attached the ADSR CV to the mixer, so it shut off the ‘stuck’ VCO.

You can see the full-voltage CV/audio output in the other pictures, with no input going into the VCO modules.

I had to restart the program a few times to get any sound out of it this time, as it was silent (even with the same input/output settings that worked before).

Is there a debug/log file I can copy to help with troubleshooting?

Hi, without something like an envelope generator controlling the VCA on the second oscillator, it will make constant sound.

At the risk of sounding rude, do you have much experience with modular synthesis?

connect de ADSR output in the cv input (the cv at the top, beside the knob) of the mixer.

a mixer is a stack of VCA, you could control the amplitude of each one of the Mixer’s VCA individually, sending CV from the ADSR to each channel, but perhaps you may control all of them at once (with the main level CV )

for other issues, like hiccups in the audio , you should try to improve the performance of your OS, decreasing the visual effects, closing no vital services and so on, on Linux you should install a low latency kernel and use jack to handle the audio, and enable the performance mode, in the rack you should enable the “real time priority” and handle the numbers of threads used in the patch, decreasing the fps can help

Thanks, CountModula and David, for your helpful replies.

Count, don’t worry - no offense taken :smiley: I am still a beginner at this modular stuff, but thought I had at least figured out the basics. Obviously still have a lot to learn. For some reason, I thought the amp was sort of ‘normalled’ inside the VCO modules, more like a regular synth (i.e. needed gate/CV to output sound). Now that I know it’s just free-running full time, that should help a lot. I played around with the program awhile back and read most of the manuals, but guess I forgot that part. It’s taken so long messing around with restarting to get any sound out at all, and I guess I forgot how VCAs work!

David, thanks for that advice as well. I’ll have to see what I can do with the Jack vs. Alsa etc.

This still doesn’t explain the audio cutouts (which also happen in Reaper, and have also happened on the faster laptop), but I have a feeling it may be related to the performance of the machine, like David said. I may have to just suck it up and upgrade my desktop, although from what I’ve read, it seems like people are getting decent results on even slower machines than this desktop.

Anyway, thanks again!

OK now that we have that sorted out, let’s look at your audio issues: Have you got the rack engine set to the same sample rate as the audio device (Engine → Sample Rate)? Have you tried reducing the video frame rate (View → Frame Rate)? What operating system are you using? Does your computer have a dedicated graphics card?

Hi Count,

I always set the sample rates to the same value when I’ve tried it in Windows (Windows 7 - need to upgrade). Computer has an Nvidia GTX970 video card. I have not tried the frame rate adjustment - I’ll give that a go, thanks.

In Linux, there’s no available Focusrite driver, so no way to check what the actual interface is set at. The few times I’ve tried running it in Linux, I’ve set it to 48k in VCV on the output module and ‘engine’ menu, as 44.1 for whatever reason sounds like it’s been badly resampled or bitcrushed or something. It doesn’t seem to do this in Windows, it just converts the rate properly, I guess.

Thanks again for your help! I’ll let you know how the frame rate thing works out, once I’ve used it for a few days. Have to get VCV out of the BSOD loop in Windows that it’s been stuck in the last two startups, first. Even telling it to initialize the patch in the startup menu didn’t work the second time.

it is not needed , use the linux driver it work flawless

Thanks David. I’ll look into that one as well.
The audio works in Pop! OS automatically (even the Focusrite), but does this driver allow changing settings as well?

I just got two more bluescreens while trying to adjust the Focusrite sample rate in the Focusrite app in Windows while VCV was open. Happened during the same action each time. Doesn’t seem to do that in Linux, so I’m guessing it might be my dying SSD (running Windows) getting worse - unless it’s a known issue. I’ve read about a few bluescreens on the forums here.

I m not sure of alsa, I think it adapt the sample rate to the source, however I recommend use Jack