Problem making the template plugin


I’m having a problem making the template project on windows 11. I’m using MSYS2 MINGW64 shell. Reading other posts, I made sure to use the right shell.

When I run make, it gives this error:

$ make
make: cc: No such file or directory
make: cc: No such file or directory
make: cc: No such file or directory
make: cc: No such file or directory
C:/path/to/sdk/ *** Could not determine CPU architecture of .  Stop.

I just followed the steps… I tried tweaking the mk and Makefiles for a few hours and it’s not working.

I would appreciate any help with this problem and thanks in advance.

Generally speaking, it’s so exhausting how Windows is unfriendly towards development and specifically audio related things. So exhausting.

I use Mac for most things and Linux for most of the rest but that indicates you are running your build command in a shell which doesn’t have a compiler or support uname. There’s a specific shell you need to use in windows (something like mingw 64 bash - it’s in the doc). Did you launch that freshly after you ran all the Pac-Man’s and stuff?

@amuuu (welcome to the forum, by the way!) The command @baconpaul is thinking of (I believe) is launch the MinGW 64-bit shell from the Start menu, not the default MSYS shell; did you do that for all stages? You say you’re using MSYS2 MINGW64 shell, so I’m guessing yes, but worth double-checking.

I’ve only ever used Windows/MSYS2 MINGW64 for Rack, but I build Rack from source for plugin development. Sounds like you’re using the SDK? In any case, happy to help.

What seems to be happening is that it’s not finding your C++ compiler. That’s the first four errors, and then fails because the MACHINE variable isn’t getting any response from cc -dumpmachine to look for substrings in.

What happens if you just run cc from the shell prompt? If that executes, what happens if you run cc -dumpmachine?

Obvious side question–that C:/path/to/sdk/ line is fictitious, right? (i.e. you edited the log?) It’s finding so I’m not worried, just checking.

It’s not really Windows, so much as that the native Rack environment is Linux and you have to run inside a layer designed to mimic linux – in this case MinGW x64. So here, whenever you want to do things in the console for Rack, it must be done from an MSYS2 MinGW X64 shell (not in any of the other MSYS2 environments).

A properly configured VSCode works well for Rack development.

@gc3 @baconpaul thank you for the reply!

I did use the MSYS2 MinGW 64 shell. The logo/icon looked the same, but the start menu name was different:


I just wiped everything related to MSYS2, installed it again. Then, as for updating packages and installing new ones using pacman, I noticed the commands didn’t ran completely (although they didn’t raise any errors or warnings). I repeated and ran them multiple times. On each repeat, although the commands ran without any errors or warnings previously, they kept installing / updating new things. Maybe it had something to do with my network connection. It finally worked.