problem: Audio Block Size is fixed on 1536

I have a motu mkii 828 usb, and whenever I try to increase the block size to more than 1024 it is fixed on this number 1536 which makes the audio noisy and glitchy. Any ideas

Using mac os

internal clock is set

also tried 41k and 48k sample rate no difference

Odd block sizes like this are rare they most usually double up for good reason they’re a multiple of the sample rate. Is there an odd sample rate for the odd 1536 block size? 7680 15,360 30,720 61,440 etc

the list of sample rates, and block sizes are usual, but it’s forced to be that number whenever choosing anything higher than 1024

idk… don’t choose it?

Shall I open a bug ticket ? since nowhere to solve it, and the sound is stuttering with this low block size

Are you trying to change it in VCV Rack, or in the motu’s settings?

I don’t use mac, but looking at a manual for motu 828 mk2, the config software has a samples per buffer setting. What value does it have there?

Block size in VCV Rack, sample rate right now is 44.1k

And what is it in the motu config software?

It’s the generic mac one, Motu Audio Setup it’s called from:

Motu Audio installer

Nothing like this?

From here

mine is USB