PatchMaster Latch Button Incompatibility

I just noticed a strange issue when trying to map a MIDI pad controller signal to a latch button in VCV.

In the example, all of the PatchMaster buttons are latch.

Mouse: The 1st mute button in PatchMaster works correctly when clicked with a mouse.

CC28: The 2nd mute button is mapped directly to MIDI pad CC28, and even though the button is latch, it doesn’t seem to process the signal any different than a momentary button

CC29: I thought maybe the issue was that the MIDI pad is outputting a gate signal, so I tried converting it into a trigger signal before mapping it to the latch button, but it didn’t seem to work at all.

CC30: The last example is a gate signal from MIDI pad CC30 that is converted into a flip/flop (latch) signal, and mapped directly to the mixer, which works. I did this because I wanted to see if it was the PatchMaster latch or the mute toggle on the mixer that was the issue, but they both functioned the same.

It’s not just MindMeld modules that do this, I noticed Bogaudio’s mixer mute buttons work the same.

I don’t understand why a latch button would want to take a gate signal, it seems like it should convert everything to a trigger signal, but even feeding it a trigger signal didn’t work as expected. It only worked when the signal was already converted into a latch?

240130-patchmaster_latch_bug.vcv (3.2 KB)

Not sure if this is relevant to anyone, but just thought I would share.

1 Like

here (Macbook M1) it works as expected!

Are you saying when you map a button to a latched button, it works correctly?

Here’s a simplified demonstration of the issue, which also shows the same thing happening with other latch buttons:

I realize it’s not isolated to PatchMaster. It may be an issue with Stoermelder’s uMap, but I think it might have something to do with how latched buttons are handled in general.

Here’s a copy of the test patch: 240130-patchmaster_latch_bug-2.vcv (1.3 KB)

You are right, there is no way to control a Patchmaster Latchbutton with another controller, it will not latch.


Simple test, push is controlling Controller 4 (set to latch), but it will not latch.

Could you use radio button mode and flip flop logic?

This is super common, as you say, and well known. I’m pretty sure the VCV MUTES module does not have this incompatibility. Those buttons are momentary, and the “latching” is done in the module’s process function.

Someone complained about this incompatibility with the mute buttons on my old mixers (which were quite popular before Mind Meld blew them away with their awesome mixers). So I changed my buttons to be like the mutes one.

It’s very easy to use a latch button, and much more cumbersome to do it the other way.

btw, please re-title this post. It is not a “bug” in PatchMaster, it’s more of an incompatibility.


Yes, that’s the workaround that I mentioned in the original post. It’s not a big deal, but it’s unintuitive and requires an additional module.

I figured there might have been some crossed signals. I imagine if they updated PatchMaster to latch properly, then it could potentially resolve the issue for every module down the line, killing all the birds with 1 stone.

Maybe there’s other considerations, but just a thought.

Ahh i missed that.

Oh, it wouldn’t necessarily screw up other modules.