osdialog_filters_parse and Linux/KDE

Hello! I have a user reporting a bug …

My Zoom audio recorder stores files with the “.WAV” extension in all capital letters. When loading samples into Autobreak Studio, I have to rename the file to end with “.wav” (lowercase) for the audio files to appear in the file browser. It would be more convenient if Autobreak Studio included “.WAV” files in the file browser results.

I tested his exact file using Windows and it shows up fine in the file browser. Here’s my file browser code:

  std::string selectFileVCV()
  {
    std::string filename_string = "";
    osdialog_filters* filters = osdialog_filters_parse("WAV:wav");  // <<======
    char *filename = osdialog_file(OSDIALOG_OPEN, samples_root_dir.c_str(), NULL, filters);

    if(filename != NULL)
    {
      filename_string.assign(filename);
      osdialog_filters_free(filters);
      std::free(filename);
    }

    return(filename_string);
  }

I think the issue has to do with him using Linux with the KDE desktop. Has anyone seen this before?

Thanks!
Bret

too quick, here seems not to matter (macOS, but yeah, silly Zoom and it’s fat16ish uppercase only filesystem)

I tried this with my own zoom recording with .WAV ending all worked all Windows 10 Rack 2 Pro

1 Like

Hi Bret, I just now tested Autobreak Studio (Voxglitch 2.23.2) on my Debian Linux system, running VCV Rack Free 2.0.6.

I created a file with the all uppercase filename FRED.WAV. I right-click on Autobreak Studio, and select “1:” under “Samples”. It opens a file browser. When I navigate to the directory where FRED.WAV is located, it does not show up. I only see other files with lowercase “.wav” extensions.

However, if I start to type “FRED” into the box, suddenly I can see FRED.WAV and open it successfully. So if you already know what the file is called, you can open it.

I will volunteer to help you run more tests if it helps.

1 Like

Don, thanks so much for testing this out! That’s great information. Maybe I’ll open a bug report with VCV Rack?

Oh, I just found a really weird thing. This might be a useful workaround until you find the real solution. In that file browser dialog box, navigate to the directory where your WAV file is. Then press the letter ‘w’ on your keyboard. It doesn’t matter whether it’s lowercase or uppercase. Suddenly all the “wav” and “WAV” files appear. Then I can pick FRED.WAV.

My theory: as soon as you start typing a letter, it shows all files that contain that letter, case-insensitively. So it shows all wav files.

Oh, awesome! I’ll pass that along to the user as a short-term fix!

Yeah, I should mention I’m using Xfce as my graphical shell. Most people don’t use that, so things might work differently in Gnome, etc. I really don’t know. However, it is suggestive that I see the same bug as the person who reported the issue to you.

1 Like