NYSTHI v2.0.10 official release

“I can feel it” is a module which does famous drum fills

3 Likes

We have Genesis related module titles Squonk, Musical Box and The Cage. Maybe the other band members solo careers could be a source of module names… Intruder (for gated reverb), Sledgehammer, Spectral Mornings, Defector…

Or something that does Enossifications (Eno’s credit on The Lamb Lies Down On Broadway), whatever that is :slight_smile:

4 Likes

shock the donkey :smiley:

4 Likes

I could use an Anti-Jazz Ray Gun

1 Like

Are these classic Serge modules? Lucky you, would love to play with one of these systems one day, and discover what they’re all about…

Sorry but NYSTHI caused crash with new build of Rack posted here - Rack development blog - #73 by Vortico at least on windows, AMD card. I remembered that was something like this back in v1 but only on laptop with 2 video adapters. But now it happens only in desktop with only one of them an end of the log: 5.156 info src/window/Svg.cpp:28 loadFile] Loaded SVG C:/Users/Artem/Documents/Rack2/plugins/NYSTHI/res/VectorMixerBis.svg [5.335 fatal adapters/standalone.cpp:49 fatalSignalHandler] Fatal signal 11. Stack trace: 49: 0x0 48: 0x0 47: _C_specific_handler 0x7ffe36127f60 46: _chkstk 0x7ffe3768ffd0 45: RtlRaiseException 0x7ffe3763b040 44: KiUserExceptionDispatcher 0x7ffe3768ebf0 43: DrvPresentBuffers 0x7ffde5834350 42: DrvPresentBuffers 0

@VCVRackIdeas you can’t use the Nysthi build for previous Rack2 CE build in new one, each plugin has to be recompiled with the new version to run

1 Like

it seems so. thanks!

oops

ok, I’ll try to cook a new release ASAP

grazie mille comparielli ! :blue_heart:

3 Likes

compiled with Rack version #219bbaf137d5dc70c96bd4206c3f8aad5524a81b 17 10 2021

v2.0.0beta2 (2021-10-19)

STEREOCHORUS-TREMOLO

NYSTEREOCHORUS

  • DEBUG: nasty NaN at the startup (in some case)
6 Likes

Thanks Antonio! Awesome that you bring them all over to v2!!!

2 Likes

Proper!

1 Like

Ubuntu 18.04 Linux VCV Rack CE v2.git.219bbaf1

Hi Antonio ! I got this error after installing the latest NYSTHI:

[0.057 warn src/plugin.cpp:166 loadPlugin] Could not load plugin /home/dlphilp/src/Rack2/plugins/NYSTHI: Failed to load library /home/dlphilp/src/Rack2/plugins/NYSTHI/plugin.so: /lib/x86_64-linux-gnu/libm.so.6: version GLIBC_2.29 not found (required by /home/dlphilp/src/Rack2/plugins/NYSTHI/plugin.so)

1 Like

I’m linking on and ubuntu 20, maybe this is the problem ?

Most likely. I’m on 18.04. No worries, I’m overdue to upgrade to 20.04 anyway. I’ll do the laptop this week, maybe get to the desktop by the weekend. Btw, is there still a “minimum Linux version” required for plugins in the Library ? (I know the Library isn’t functional yet in v2, I’m just wondering about the version requirement.)

Best regards,

dp

“you must compile against glibc 2.23 and libstdc++ 5.4.0”

“I use Ubuntu 16.04 on Docker for all Plugin Manager automated builds”

As far as I know this is still the requirement. This should all be in the manual of course, but as far as I can tell it still isn’t :-/ @cschol can probably answer authoritatively besides Andrew.

2 Likes

can you try this one?

I recompiled on a fedora 26 (as I was doing all my releases before)

https://github.com/nysthi/nysthi/releases/download/v2.0.0b2/NYSTHI-2.0.0b2test2-lin.zip

grazie

Done and done. Ah, the sweet sight of NYSTHI in the v2 browser ! Thank you, Antonio, again. :slight_smile:

3 Likes

There isn’t a “minimum Linux version” for plugins but a minimum libc version of 2.23. That version just happens to be present in Ubuntu 16.04.

The official Rack toolchain builds the very latest gcc compiler 11.2, but compiles against libc 2.23 specifically. The toolchain does not use the host systems compiler, so it is independent of the OS type and version. The Docker image, which the toolchain can be built in, is actually Ubuntu 20.04 (arbitrary choice, because I prefer Debian-based systems). Nevertheless, it builds a compiler infrastructure that is based on the latest gcc and libc 2.23.

Christoph

3 Likes

Thanks Christoph.

And is libstdc++ 5.4.0 also still a requirement, like Andrew said in the quote above?

Two ideas:

  1. It would be great to have this documented in the official manual.
  2. It would probably be very useful for all developers, if there was a downloadable docker container with Linux and the right toolchain and libs, that they could simply use and not have to worry about having the right host system. Maybe Alpine based or something to keep the size down.