No text keyboard input in Rack 2 Pro within DAW?

Hi, been using VCV Rack 1 since forever and I finally just made the jump up to Rack 2 Pro. I just loaded it into Ableton for the first time and I’m finding I get no keyboard input whatsoever inside the plugin. No delete, undo, copy/paste, etc… and the biggest dealbreaker… I can’t type anything in the library searchbar, or label anything in my patch. Yikes!

Am I missing something? Is this a known issue? And is there a workaround? Thanks!

There must be an option to give the plug-in keyboard focus in the Ableton settings. Just search for that or wait until an Ableton user comes along…

Oh BTW Mac Linux Windows?

And also: VST2i, VST2 FX, VST3, AU?

Probably a silly question, but have you left-clicked in the Rack window to give it focus? Sometimes a DAW won’t give focus to the plugin window unless you explicitly left-click.

1 Like

AU plugin on an M1 macbook air (running native, not rosetta2). Oddly I don’t see the VST or VST3 as an option in Ableton Live 11.3. I’ve run the Rack Pro installer twice now. I can’t get the VSTs to show up.

And upon further investigation, I get working keyboard controls when I first launch the AU plugin, but after working on a patch for about 10 mins at some point it loses keyboard input. Once it drops off, there’s no getting it back. Clicking in the search bar in the module browser (or anywhere on the plugin interface) doesn’t fix it.

You are running Ableton in M1 mode without rosetta, so you will not be able to see the vst or vst3 version of Rack pro.

1 Like

I reported a similar problem with the AU plugin in Logic Pro to VCV Support. In my case, keyboard events intended for the plugin window (even after left clicking for focus) are sometimes instead delivered to the main Logic window - which can be disconcerting (type a number and Logic tries to interpret it as a “screen set change”). For me, I can usually get things back to normal by closing the plugin window and reopening it.

Definitely suggest you send detailed bug report to support - they are very responsive.


Ok thanks! And good to know about the vst M1 incompatibility. It seems to be working smoothly now as vst running in rosetta.

1 Like

Just set the “off” multiple windows at ableton’s preferences. that’s all.

1 Like